Page MenuHome

Vertex and weight paint mode broken after using sculpt mode mask tools
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-8.1-6.3.9600-SP0 64 Bits
Graphics card: GeForce GT 710/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.66

Blender Version
Broken: version: 2.83 (sub 8), branch: master, commit date: 2020-03-12 00:33, hash: rB8751af6d1902
Worked: last older 2.83 build I have: c26f470cfeea

Short description of error
using sculpt mode breaks vertex paint mode after being used

Exact steps for others to reproduce the error

  1. Open file
  2. Go to sculpt mode
  3. Use the Mask or the Box Mask tool once
  4. go back to vertex paint mode

it has a really bad visual glitch.(it gets even worse if you use dytopo)
also note that the glitch disappears if you enter the rendered or the preview mode and go back to solid.

note this doesnt seem to be a problem when mesh is subdivided by a modifier [subd/multires]

more info from T75567:

bug is related to Masks and Face Sets overlays from Sculpt mode.
First, create a mask or a face set is created in Sculpt mode.
Then, switch to vertex paint mode or weight paint mode.
There is no problem if mesh is subdivided by a modifier. But if there is no modifier, there are artifacts.
Some faces may be black. Others became colored tris in vertex paint mode.
In weight paint mode, colors other than blue may be black.
Then, go back to sculpt mode to disable Face Sets and Masks overlays.
And finally, switch again to vertex paint mode. -> glitches are gone.

It looks like overlays (non pertinent in Vertex or Weight Paint mode) are still active in a viewport when switching from Sculpt mode to Vertex or Weight Paint mode.
That does not happen if you switch from one workspace dedicated to Sculpt mode to another dedicated to a Paint mode.


after using dytopo:

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Confirmed.Mar 13 2020, 1:13 PM
Richard Antalik (ISS) updated the task description. (Show Details)
Jacques Lucke (JacquesLucke) changed the subtype of this task from "Report" to "Bug".Mar 18 2020, 3:30 PM

This also breaks weightpaint...

Philipp Oeser (lichtwerk) renamed this task from Vertex paint mode broken after using sculpt mode to Vertex and weight paint mode broken after using sculpt mode.Mar 19 2020, 4:04 PM
Philipp Oeser (lichtwerk) raised the priority of this task from High to Unbreak Now!.
Jeroen Bakker (jbakker) lowered the priority of this task from Unbreak Now! to High.Mar 30 2020, 9:57 AM

Not sure why this has been raised to Unbreak Now! Check https://wiki.blender.org/wiki/Process/Bug_Reports/Triaging_Playbook Priority Clarifications section

Issue seems to be fixed in latest master @Philipp Oeser (lichtwerk) could you recheck?

Not sure why this has been raised to Unbreak Now! Check https://wiki.blender.org/wiki/Process/Bug_Reports/Triaging_Playbook Priority Clarifications section

Issue seems to be fixed in latest master @Philipp Oeser (lichtwerk) could you recheck?

Well, according to the playbook, yes, this should "only" have been High, true [looked pretty bad though, since it seemed you can not recover from that corruption...]
Anyways, seems to be fixed for me, I was talking to @Pablo Dobarro (pablodp606) about this, could you confirm you have been doing something to fix this?

Philipp Oeser (lichtwerk) closed this task as Resolved.Mar 30 2020, 8:08 PM
Philipp Oeser (lichtwerk) claimed this task.

So, this was fixed by one of the recent Face Sets fixes it seems (havent hunted down the exact commit).

Closing as resolved (feel free to comment again if issues persist...)

Philipp Oeser (lichtwerk) reopened this task as Confirmed.Apr 8 2020, 2:36 PM

Sorry to say, but just discovered that this still happens if you use any of the masking tools

Philipp Oeser (lichtwerk) renamed this task from Vertex and weight paint mode broken after using sculpt mode to Vertex and weight paint mode broken after using sculpt mode mask tools.Apr 8 2020, 2:37 PM
Philipp Oeser (lichtwerk) updated the task description. (Show Details)

Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: Intel(R) HD Graphics 5500 Intel 4.4.0 - Build 20.19.15.5070

Happening on my end still.

Issue is when switching directly from sculpting to weight/vertex paint the sculptsession is still that one from sculpting that makes the overlay to be drawn by the pbvh drawing method but renders it incorrectly as to many assumptions are made about the attached shaders etc.

Best fix would be to have the correct sculpt session on the object we are rendering. second option is to add a check around the sculpt overlay that the object is actually in the correct mode and don't trust the setting in the sculpt session.