Page MenuHome

Render cloth animation does not resets cache
Confirmed, NormalPublicBUG

Description

Blender Version
Broken: 2.82.7
Worked: 2.79b

Short description of error
When modifier Subdivision is before the cloth physics modifier,but with different subdivision settings for rendering and viewport, the cache remains active even when rendering.
Possibly related to T74523.

Exact steps for others to reproduce the error

  • Open attached file
  • Run animation (without baking)
  • Render animation

Notice that the cloth is deformed with each rendered frame.
This is because rendering reuses the cache.

Event Timeline

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Confirmed.Fri, Mar 13, 7:58 PM
Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Bug".
Evan Wilson (EAW) closed this task as Invalid.Fri, Mar 13, 8:14 PM
Evan Wilson (EAW) claimed this task.

Thank you for the report. This is noted in the manual under the cache settings under cloth simulations.

https://docs.blender.org/manual/en/dev/physics/cloth/settings/cache.html

Evan Wilson (EAW) reopened this task as Confirmed.Fri, Mar 13, 8:16 PM

While getting the manual page and checking other similar reports, I see @Germano Cavalcante (mano-wii) already triaged this, so I will set it back to his status and subtype.

Germano Cavalcante (mano-wii) changed the subtype of this task from "Bug" to "Known Issue".Fri, Mar 13, 8:28 PM

I actually edited the description and added the "bake" information.
But the problem with the cache after bake seems to be a known issue.
The original report seemed to be more of a problem with the cache not being reset when rendering the animation.
I will test and re-edit the description.

Germano Cavalcante (mano-wii) renamed this task from Render displays cloth with Subdivision unnormal to Render cloth animation does not resets cache.Fri, Mar 13, 8:38 PM
Germano Cavalcante (mano-wii) updated the task description. (Show Details)
Germano Cavalcante (mano-wii) changed the subtype of this task from "Known Issue" to "Bug".
Evan Wilson (EAW) removed Evan Wilson (EAW) as the assignee of this task.Sat, Mar 14, 2:39 AM