Page MenuHome

Glitchy view after Undo in Sculpt mode with hidden mesh.
Confirmed, NormalPublic

Description

System Information
Operating system: Windows 10.
GPU: GTX 1060m.

Blender Version
Broken: 2.82 and 2.83 alpha.
Working: 2.79b

Short description of error
Visual glitches appear when undoing with a hidden mesh in sculpt mode. Vertex paint mode also looks glitchy after doing this, but only in wireframe view and with overlays turned on. It stops happening if the meshes are moved away from each other. It only happens in solid and wireframe view, with eevee it looks just fine. Going back to Object mode or edit mode makes the glitches disapear.


Exact steps for others to reproduce the error
Open attached file.
Go to Edit Mode
H to hide the mesh (happens when hidding either mesh)
Go to Sculpt mode
sculpt a bit
Ctrl+Z
boom

Event Timeline

I have no clue who should look it up. Bastien as it's undo related, Clément as it is workbench related, or pablo dobarro...

Ankit (ankitm) changed the task status from Needs Triage to Confirmed.EditedThu, Mar 19, 8:51 AM
Ankit (ankitm) added a subscriber: Ankit (ankitm).

Do you remember the working blender version ?

rB82c51d0edbab45f014b4d0b4c0a96c000c46e232
Operating system: Darwin-18.7.0-x86_64-i386-64bit 64 Bits (10.14, Mojave )
Graphics card: Intel(R) HD Graphics 6000 Intel Inc. 4.1 INTEL-12.10.12

A blender version with no glitches would be helpful

I could'nt open the file in 2.79, then imported it as FBX and it works just fine, no glitch at all in 2.79b.

2.81 and above, all have the bug. 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e is working and doesnt have the bug.