Page MenuHome

GPUShader: compile error on opening blender
Closed, InvalidPublic

Description

System Information
Operating system: Linux Mint
Graphics card: 4.4.0 NVIDIA 340.107

Blender 2.83 (sub 9), Commit date: 2020-03-18 15:41, Hash 9e382dd2a3d8

Backtrace
/home/xuse/soft/blender283/blender(BLI_system_backtrace+0x1d) [0x7404e0d]
/home/xuse/soft/blender283/blender() [0x16b5a32]
/lib/x86_64-linux-gnu/libc.so.6(+0x3ef20) [0x7fb2c0306f20]
/home/xuse/soft/blender283/blender(GPU_shader_get_uniform_block+0x4) [0x611d2c4]
/home/xuse/soft/blender283/blender() [0x1a9ecbb]
/home/xuse/soft/blender283/blender(DRW_shgroup_create+0x1c) [0x1aa09bc]
/home/xuse/soft/blender283/blender(workbench_antialiasing_cache_init+0xfe) [0x1afc0ee]
/home/xuse/soft/blender283/blender(workbench_cache_init+0x39) [0x1ac0669]
/home/xuse/soft/blender283/blender() [0x1a9b146]
/home/xuse/soft/blender283/blender(DRW_draw_render_loop_ex+0x3a4) [0x1a9c5d4]
/home/xuse/soft/blender283/blender(view3d_main_region_draw+0x8f) [0x209c9cf]
/home/xuse/soft/blender283/blender(ED_region_do_draw+0x8f1) [0x1cb91b1]
/home/xuse/soft/blender283/blender(wm_draw_update+0x527) [0x1962197]
/home/xuse/soft/blender283/blender(WM_main+0x30) [0x19600a0]
/home/xuse/soft/blender283/blender(main+0x321) [0x15ec8f1]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) [0x7fb2c02e9b97]
/home/xuse/soft/blender283/blender() [0x16b225c]

Blender Version
Broken since: blender-2.83-7ba403dc94c3
Worked: blender-2.83-212660f46745

When trying to launch from cmd, I get:
found bundled python: /home/xuse/soft/blender283/2.83/python
GPUShader: compile error:
0(621) : error C0105: Syntax error in #if
0(621) : error C0105: Syntax error in #if
0(622) : error C0000: syntax error, unexpected '!' at token "!"
0(623) : error C0000: you must define the shading language: SMAA_HLSL_*, SMAA_GLSL_* or SMAA_CUSTOM_SL
0(640) : error C0000: syntax error, unexpected reserved word "return" at token "return"
0(654) : error C0000: syntax error, unexpected reserved word "return" at token "return"

Writing: /tmp/blender.crash.txt
Segmentation fault (core dumped)

I also deleted the preferences to force a clean start, but with the same result.

Event Timeline

voxel9 created this task.Thu, Mar 19, 7:58 AM
Ankit (ankitm) renamed this task from Blender crash when trying to start it to GPUShader: compile error on opening blender .Thu, Mar 19, 12:25 PM
Ankit (ankitm) edited projects, added BF Blender; removed BF Blender (2.83).
Ankit (ankitm) added a subscriber: Ankit (ankitm).

can you retry a make update ?

Ankit (ankitm) changed the task status from Needs Triage to Needs Information from User.Thu, Mar 19, 12:25 PM

Can you give me, please, few more details? I'm not quite that technical. If you're talking about GNU make, my system has version 4.1 and that seems to be the latest in the Linux Mint repository. I checked gnu.org and their last version is 4.3. I could try to install it if that is what you're suggesting, but I have to read about how to do it. If you're talking about compiling Blender from sources, I didn't try that yet.

Ankit (ankitm) added a comment.EditedFri, Mar 20, 2:52 PM

I updated the drivers to 435.21 (it was a pain!) and now it's working again.
Thank you Ankit for your support. From my side, you may close this task.

Ankit (ankitm) closed this task as Invalid.Mon, Mar 23, 11:45 AM
Ankit (ankitm) claimed this task.

Marking invalid since not a bug. Hopefully it would work for Igo too.