Page MenuHome

Grease Pencil: Edit mode crashes 2.83 (unstable alpha)
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10, 64bit
Graphics card: none (CPU)

Blender Version
OK: V 2.82a
Crash: V 2.83-c9c08dc7c873-windows64 2020-03-18 17:16 (unstable alpha)
Crash: V 2.83-d2c3544c5cb0-windows64 2020-03-19 21:12 (unstable alpha)

Exact steps for others to reproduce the error

  • open blender
  • click 2D animation on the splash screen
  • press tab-key, or use dropdown menu to change from Draw to Edit mode
  • blender quits to desktop

Revisions and Commits

Event Timeline

Eitan (EitanSomething) changed the task status from Needs Triage to Needs Information from User.Fri, Mar 20, 2:00 PM

Please include the system-info.txt generated from the Help > Save System Info Menu will give information about the OS, hardware, drivers, Blender version and add-ons enabled.

system info:

console output could also be helpful
C:\Program Files\Blender Foundation\blender-2.83-c9c08dc7c873-windows64>blender.exe
Read prefs: C:\Users\Gabriel\AppData\Roaming\Blender Foundation\Blender\2.83\config\userpref.blend
found bundled python: C:\Program Files\Blender Foundation\blender-2.83-c9c08dc7c873-windows64\2.83\python
GPUShader: compile error:
ERROR: 4:397: '&' : wrong operand types no operation '&' exists that takes a left-hand operand of type 'attribute uint' and a right operand of type 'const bool' (or there is no acceptable conversion)
ERROR: 4:397: ';' : syntax error syntax error

Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF7F94BED64
Module : C:\Program Files\Blender Foundation\blender-2.83-c9c08dc7c873-windows64\blender.exe

should I try any debug flags to add details to the console output?

Eitan (EitanSomething) closed this task as Invalid.Fri, Mar 20, 2:29 PM
Eitan (EitanSomething) claimed this task.
This comment was removed by Eitan (EitanSomething).
Ankit (ankitm) reopened this task as Needs Triage.Fri, Mar 20, 2:46 PM
Ankit (ankitm) removed Eitan (EitanSomething) as the assignee of this task.
Antonio Vazquez (antoniov) changed the task status from Needs Triage to Needs Information from User.EditedFri, Mar 20, 4:09 PM

I cannot reproduce it on Windows 10 NVIDIA RTX2080TI.

I tlooks a GPU driver problem because the error is a shader compilation error.

I've also experienced this crash while using in Intel HD4000. However, I also get the crash when attempting to enter Sculpt, or Weight Paint mode. I attached my own system-info.txt from this version, and a .blend, if that's helpful.


The report from "report a bug" within Blender also gives this:

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: Intel(R) HD Graphics Intel 4.0.0 - Build 10.18.10.4425

Blender Version
Broken: version: 2.83 (sub 10), branch: master, commit date: 2020-03-20 19:52, hash: rB9607e5498583
Worked: 2.82a

The graphics driver version is too old. Please upgrade to the latest driver, see here for more information: https://docs.blender.org/manual/en/dev/troubleshooting/gpu/index.html

At least for me, as far as I can tell after trying to update it, my driver is up to date. Unfortunately for me my computer may be too old (not sure if the same is true for OP).

However, I also get the crash when attempting to enter Sculpt, or Weight Paint mode.

Yep, Sculpt and Weight Paint also crash my 2.83.

My PC is 8 years old, and has no dedicated graphic card.
I didn't think, that a 'minor' version step 2.82->2.83 would break compatibility. That's why I reported.

If you say, there is a new feature in 2.83 that needs better hardware, and my old hardware is only supported till 2.82, then I'm perfectly fine with that answer.

If you say, the compatibility break was not intended, and you'd like to investigate, then I'm happy to perform any test that might help you.

Best
Gabriel

Today i got similar result while testing on my old windows 7 notebook with mobility radeon HD 4300/4500.

After some play with drivers i got 2.82 and 2.83 to launch (2.79 is fine at all) but for 2.83, when going to 2D Animation, Blender 2.83 crashes and console says EXCEPTION_ACCESS_VIOLATION and that it needs video card with 3.0 SHADER SUPPORT.

Also 2.82 and 2.83 UI is totally flashing/flickering... it seems oldies can go with 2.79 only :(

@Gabriel (gabi2002) The Intel HD Graphics 4000 should still work. Your graphics driver appears to be quite old though, please try to update it. The newest driver can be downloaded from the Intel website. Please report back if this solved your problem.

@Dmitry (Rezoob) The AMD Radeon HD 4000 series doesn't fulfill the minimum requirements for running Blender 2.8x. Only AMD GPUs with the GCN first generation architecture and later are supported. The AMD Radeon HD 4000 series has the old TeraScale 1 architecture.

@Robert Guetzkow (rjg) Thank you very much for your patient investigation!

I thought, I had updated the drivers, because Blender (2.82) had warned me about my old hardware/driver.
I'm a bit surprised the drivers are 'old again' one month later. Maybe, I somehow messed up the update process.

I updated the drivers again today.
before: '4.0.0 - Build 10.18.10.5100'
now: '4.0.0 - Build 10.18.10.5129'


Unfortunately, I still get the same warning and the same crashes.
Looks more and more, it's really my hardware and Blender or the driver :(

Best
Gabriel

Robert Guetzkow (rjg) changed the task status from Needs Information from User to Needs Developer to Reproduce.Fri, Mar 27, 12:26 PM

@Germano Cavalcante (mano-wii) thank you again! I can happily confirm, there are no more crashes with v2.83 alpha 2020-03-28 01:08 79b391f3a009

Best
Gabriel