Page MenuHome

GPencil: Strokes get darker while drawing in SOLID mode
Closed, ResolvedPublicBUG

Description

Using last 2.83 version when drawing in solid mode, the stroke get darker and darker.

Event Timeline

Antonio Vazquez (antoniov) changed the task status from Needs Triage to Confirmed.Mar 24 2020, 10:49 AM
Antonio Vazquez (antoniov) created this task.
Antonio Vazquez (antoniov) changed the subtype of this task from "Report" to "Bug".

The reason is the TAA. Due to the current implementation the workbench updates the default color texture of the viewport what leads to these artifacts.
If you switch off TAA this should not happen.

Similar artifacts can be seen when doing weight painting or using a camera background image. I reverted the commit introducing it.

Using last 2.83 version

I thought you meant the latest, so I was first looking at the commits from the last 24 hours as subversion was just bumped to 2.83.11 in rB24b27ea23115 =)

v2.83.9 is in the corner of the video

Subversion was bumped to 2.83.9 in rBa210b8297f5a on March 14th.

Subversion was bumped to 2.83.10 in rBb62e1146e13c on March 18th.

So this has been around at least that long. Do you have the hash of the build you were using? I assume you are using a tablet when drawing. Is this correct @Antonio Vazquez (antoniov)?
For others looking at this, a note:
Using a mouse, I didn't notice this at first. The lines just appeared to start off fully opaque black in solid mode. I thought that maybe the behavior had changed since 2.83.9. Further testing shows that it takes 5 mouse movements of a pixel each for the strokes to go from the default color strength to fully black. So it would appear that the behavior is still the same, just that a mouse and (I am assuming) a tablet with pressure sensitivity produce the results at different rates.


Tested using version rB94b8166a8b05
Windows 10
NVIDIA GeForce GTX 470/PCIe/SSE2 4.5.0 388.13

@Jeroen Bakker (jbakker) I just built master rBb759857825b8 (with your revert) and now I get the same behavior as in the video, where the opacity slowly builds to black.

rB58ac113b76d9 was committed yesterday, @Antonio Vazquez (antoniov) appears to be using a version somewhere between rBa210b8297f5a and rBb62e1146e13c according to the subversion number.

See @Campbell Barton (campbellbarton), and @Harley Acheson (harley), subversion numbers in the corner can be helpful! ;p

A video to show the two behaviors.

Hi @Evan Wilson (EAW)

Can you confirm that rB28c3d952dbde: Fix T74782: WorkBench TAA Artifacts During Painting/Drawing fixed both issues? I did test myself, but better to be sure :-)

@Jeroen Bakker (jbakker) I have built rB7ac5c5b08cdd (which includes rB28c3d952dbde) and can confirm that both issues are gone, it is working as intended! =)

Eitan (EitanSomething) closed this task as Resolved.Mar 24 2020, 4:59 PM
Eitan (EitanSomething) claimed this task.