Page MenuHome

Blender using integrated GPU, not dedicated
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10 pro (10.0.18363) x64
Graphics card: Intel(R) HD Graphics 530 and NVIDIA GeForce GTX 1060 6GB

Blender Version
Broken: 2.82
Worked: No one

Short description of error
When I try to open Blender, appears a small black window and instantly disappears. So i can't access to the program.

Exact steps for others to reproduce the error
I only try to open the program.

Event Timeline

Evan Wilson (EAW) changed the task status from Needs Triage to Needs Information from User.Tue, Mar 24, 5:14 PM

Thank you for the report. Your computer is telling Blender to use the Intel integrated card instead of the NVIDIA.

On your computer, click the Windows Start button, then the settings button. Type "control panel" in the search. Open the control panel. Open the NVIDIA control panel. Under "3D settings"->"Manage 3D settings" set the "OpenGL rendering GPU" to your 1060. You can set this globally or just for Blender.

Does that fix the issue for you?

Thanks, well the problem is that now when I try to open NVIDIA Control Panel, says that I don't have an NVIDIA card conected so I don't know what to do. I reinstalled the drivers of the card, but nothing...

Ankit (ankitm) renamed this task from The program closes automatically when I open it to Blender using integrated GPU, not dedicated .Wed, Mar 25, 6:15 PM

Try running blender_debug_gpu_glitchworkaround.cmd in blender directory. If it works, it'd probably be closed as dupe of T72098: Crash on startup with 2.82 and Intel HD + Windows

What is the make and model of your computer, and what driver do you have installed?

The driver currently installed is 26.20.100.7262
https://www.dell.com/support/home/in/en/inbsd1/drivers/driversdetails?driverid=654r9
last updated: 06 Jan 2020

You should be using the one by intel, 26.20.100.7985
https://downloadcenter.intel.com/product/88345/Intel-HD-Graphics-530
last updated: 25 march 2020

Is your monitor plugged into the motherboard or the GPU? Or is this a laptop @Fran Guerrero Vicente (FranGV98)? Is there an external monitor plugged in?

Also, please try using the latest Studio driver.
https://www.nvidia.com/Download/driverResults.aspx/156784/en-us

And if that doesn’t work, the latest game ready driver.

https://www.nvidia.com/Download/driverResults.aspx/159091/en-us

So far all reports we have received recently on this issue involve Intel 620/530, NVIDIA Pascal cards, and two specific NVIDIA drivers.

Is your monitor plugged into the motherboard or the GPU? Or is this a laptop @Fran Guerrero Vicente (FranGV98)? Is there an external monitor plugged in?

That was the problem 🤦. Thanks so much

That was the problem 🤦. Thanks so much

@Fran Guerrero Vicente (FranGV98) Just to be clear, in order to help others who have reported similar issues, was it that your monitor was plugged into the mother board, and that is why your GeForce GTX 1060 wasn't showing up in the NVIDIA control panel?

Does Blender work fine now? If so, or even if not, can you please upload the blender_system_info.txt?

That was the problem 🤦. Thanks so much

@Fran Guerrero Vicente (FranGV98) Just to be clear, in order to help others who have reported similar issues, was it that your monitor was plugged into the mother board, and that is why your GeForce GTX 1060 wasn't showing up in the NVIDIA control panel?
Does Blender work fine now? If so, or even if not, can you please upload the blender_system_info.txt?

Yes. The problem was that the monitor was plugged into the mother board. Once I changed the connection, blender worked fine and now I don't have any problem.

Thanks so much for your help. 10/10.

Eitan (EitanSomething) closed this task as Invalid.Sun, Mar 29, 8:12 PM
Eitan (EitanSomething) claimed this task.

You are most welcome. Before I close this, could you let me know what NVIDIA driver you are using? It might help the others.

It still really shouldn't crash on startup when using the Intel HD 530 card, but I assume it's the same as T72098: Crash on startup with 2.82 and Intel HD + Windows.