Page MenuHome

Library Override: Moving Linked Armature into an unlinked collection breaks skinning.
Closed, ArchivedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce RTX 2070 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.19

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-03-12 05:06, hash: rB375c7dc4caf4
Worked: (optional)

Short description of error
I had some files where the Linked Library Overide Armature lost it's skinning when I opened them in this version of Blender.
(The linked armature had been moved into a different collection).

Exact steps for others to reproduce the error

2min video to demo the issue:

  • from a new scene, make a link to the supplied Cletus_rig.blend file.
  • from the link options select 'Collection' as type, and select the 'Cletus_rig' collection.
  • create a new collection in the scene called 'TestCollection'.
  • select the linked collection, and go to Object/relationships/Make Library Override
  • in the popup window select the 'Armature' object.
  • save the scene to a tempory file.
  • create a new scene.
  • re-open the tempory scene.
  • grab the armature, go into pose mode, grab an arm and rotate, skinning will be lost.

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.Apr 3 2020, 4:28 PM
Philipp Oeser (lichtwerk) changed the subtype of this task from "Report" to "Bug".

Can confirm.

If I do the "setup" in current master, I cannot open the scene anymore without running into the following assert:
BLI_assert failed: /blender/source/blender/makesrna/intern/rna_collection.c:140, rna_Collection_objects_override_apply(), at '0 && "invalid source or destination object."'
If I do the "setup" in 2.82, I dont get the assert, but can confirm the findings of @Malcolm Reed (mal_reed) .
Looks like a bug to me...

CC @Bastien Montagne (mont29)

Philipp Oeser (lichtwerk) renamed this task from Moving Linked Armature into an unlinked collection breaks skinning. to Library Override: Moving Linked Armature into an unlinked collection breaks skinning. .Apr 3 2020, 4:29 PM
Bastien Montagne (mont29) closed this task as Archived.Apr 9 2020, 12:10 PM
Bastien Montagne (mont29) claimed this task.

This is not supposed to work, you should not edit (add, remove or move objects) in an overridden collection... You can link your armature to another extra collection, but not move it there. At least in current situation, this may change, but there is no bug here currently.