Page MenuHome

File browser should accept full paths in file input
Closed, ArchivedPublicBUG

Description

System Information
Operating system: windows 10
Graphics card: 2080ti

Blender Version
Broken: 2.82 Windows
Worked: 2.82 Linux

Short description of error
The file browser used to load and save files has its file path split up into 2 parts. The top of the window has a section for the folder and the bottom has a section for the filename.

To be standard with other window applications it should be possible to do everything with the bottom "file" input.

In the bottom input section user should be able to;

  • Type/paste a directory (C:\Assets\House) in and open that folder
  • Type/paste a full filepath (C:\Assets\House\Door.blend) in and save to that file

My apologies if this is not a bug, initially I put it on rightclickselect as a feature but someone commented saying it worked in linux so therefore may be considered a bug.
https://blender.community/c/rightclickselect/drfbbc/#5e6e02a69c1221214ad66b4a

Exact steps for others to reproduce the error
While in windows, start blender and try to save the file by typing the whole path into the bottom file input. eg "C:\folder\file.blend"
Notice how it will save to "C:\folder\file.blend\untitled.blend"

Event Timeline

Ankit Meel (ankitm) renamed this task from File browser should accept full paths in file input to File browser should accept full paths in file input like in Linux.Apr 5 2020, 1:11 PM

Likely some bad handling of the backslash path separator here? Anyway, would be easier for some windows dev to investigate this… gentle poke at @Ray molenkamp (LazyDodo) ;)

Otherwise will have to spend some time dusting off again my VM and whole blender build chain there. ;)

Bastien Montagne (mont29) triaged this task as Low priority.Apr 6 2020, 4:58 PM
Bastien Montagne (mont29) changed the subtype of this task from "Report" to "Bug".
Bastien Montagne (mont29) moved this task from Backlog to Bugs on the Pipeline, Assets & I/O board.

I always assumed this was because blender cut the path (upper part of the dialog) and filename (bottom part of the dialog) into two separate things unlike any file dialog on this platform.

The filename part is being run though BLI_filename_make_safe in file_filename_enter_handle which replaces all 'bad characters' with an underscore (including /) we sure this is actually working on linux?

@Ray molenkamp (LazyDodo) : nope, this is the same on linux (at least for me) -- forward slashes replace by underscore.
Not sure this is really a bug?

Sebastian Parborg (zeddb) closed this task as Archived.Apr 6 2020, 5:53 PM
Sebastian Parborg (zeddb) claimed this task.

This is not a bug as the bottom field is only intended for filename input. (At least currently)

Ankit Meel (ankitm) renamed this task from File browser should accept full paths in file input like in Linux to File browser should accept full paths in file input.Jun 12 2021, 7:10 PM

To add my two cents:

  • I agree the bottom input should accept full paths.
  • Having the bottom input convert filenames into “safe” variants is unwanted functionality, especially for dialogs displayed for opening files (in contrast to save dialogs).
  • I also think it’s wrong for the top input (folder path) to suggest creating a new directory when a path that doesn’t yet exist is entered. Having a dedicated button on the dialog for creating a new folder is the way to go.