Page MenuHome

Cycles adaptive sampling gives noisy denoising shadow pass
Confirmed, NormalPublicBUG

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce GTX 970/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 426.00

Blender Version
Broken: version: 2.83 (sub 13), branch: master, commit date: 2020-04-08 21:23, hash: rB1239cab11ff9
Worked: 2.82a

Short description of error
Dots in denoised render.

Exact steps for others to reproduce the error
Try to render the file in 2.82a (no dots) and in 2.83 (dots) as seen on this pic (I made it lighter in pshop to emphasize the difference)..

It seems it comes from the lighting because if I suppress any light source, the problem disappears.
I am aware that it's not a "big" bug and it is very peculiar to these lights, but nevertheless I keep you informed.

Event Timeline

The issue actually branches from adaptive sampling. If you turn this feature off, the issue will go away. You could also try increasing the "minimum samples" setting (20 worked for me) or increase your overall sample count (128 fixed it for me). It should be noted that increasing your overall sample count also increases your minimum sample count ( if it's set to 0/auto) which is why it works.

However, this is still a bug, so I'll leave this thread open for the developers to review.

Richard Antalik (ISS) changed the task status from Needs Triage to Confirmed.Apr 14 2020, 6:11 PM
Brecht Van Lommel (brecht) renamed this task from Normal Denoise 2.83 faulty to Cycles adaptive sampling gives noisy denoising shadow pass.May 14 2020, 1:17 AM
Brecht Van Lommel (brecht) edited projects, added Cycles; removed Rendering.
Brecht Van Lommel (brecht) changed the subtype of this task from "Report" to "Bug".

Both adaptive sampling and the denoising shadow pass use even/odd samples, maybe there is some conflict.