Page MenuHome

New multires shrinkage problem
Closed, ResolvedPublic

Description

System Information
Operating system: ubuntu 16.04
Graphics card:

Blender Version
Broken: newest master, a8d139ca2002
Worked: older version / 2.7x

Short description of error
subdividing with a multires modifer will result in a "non standard" catmull clark mesh

Exact steps for others to reproduce the error

just subdivide a cube and compare it to a subsurf cube

the reason for that behavior is (i guess) multires subdivides the limit surface mesh again and again which is obviously wrong/unpredictable... (it is exactly reproducible with multiple subsurf modifier on one mesh)

Event Timeline

I can confirm this issue.
2.82 and even 2.79 both doesn't have this problem...

Ankit Meel (ankitm) changed the task status from Needs Triage to Confirmed.Apr 15 2020, 8:13 AM

Any news on a fix for this?
I suppose it should be fixed for 2.83?

@ThinkingPolygons (ThinkingPolygons) I appreciate your enthusiasm, but please stick to discussing about fixing or reproducing the issue here. Since you are subscribed to this task you will already receive notifications about a fix when it comes to that.

It felt forgotten, that's why I asked.
But don't worry, it won't happen again.

Sergey Sharybin (sergey) closed this task as Resolved.Apr 24 2020, 10:42 AM
Sergey Sharybin (sergey) claimed this task.

The Fix prefix in the commit message got lost. So markign as resolved manually.
Thanks for the report!

It felt forgotten, that's why I asked.

And I'm glad you did ask. The issue is now fixed! Yay

@Nelson (NAS) I know you have good intentions, but please refrain from encouraging this behaviour any further. And from doing it yourself - T75325#905524.

This affect negatively the development process. It adds pressure to developers, and often lead to non-priority items taking over the agenda.

I consider this topic over. If anyone wants to discuss this any further please write me on dalai@blender.org.

@Dalai Felinto (dfelinto) Well, I'm not encouraging anything, also I don't see anything wrong about asking for information on tasks/patches that seems to be forgotten, but if you think this is bad, then so be it!