Page MenuHome

Mesh artefacts when using Clay Strips and a high Tip Roundness value
Confirmed, NormalPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 980/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.50

Blender Version
Broken: version: 2.83 (sub 13), branch: master, commit date: 2020-04-11 15:16, hash: rB85de07e64c96

Short description of error
I encountered a visual bug of the mesh after using Clay Strips with certain settings. In particular I noticed that Tip Roundness creates mesh artefacts the higher the value. However, it doesn't actually destroy the topology, since I was able to reset the mesh so it looks normal again pretty easily by just smoothing.

Exact steps for others to reproduce the error

  1. Copy the brush settings as shown in this screenshot.

  1. Start sculpting on a mesh. It should produce the artefacts quickly with Tip Roundness set at 1.000.
  1. Smooth once the areas of the sculpt where the artefacts appear. They should disappear completely.
  1. Pressing undo after smoothing will show the correct mesh with all artefacts gone.

Event Timeline

@Kenn Nyström (Frozen_Death_Knight) Can you please upload sample .blend file? I have quite trouble reproducing.

Ankit (ankitm) changed the task status from Needs Triage to Needs Information from User.Mon, May 4, 10:30 AM
Ankit (ankitm) added a subscriber: Ankit (ankitm).

I have quite trouble reproducing.

Me too.

@Richard Antalik (ISS) @Ankit (ankitm) Here's is the original file I was sculpting with.


Just increase tip roundness on the Clay Strips brush to max and just go full ham on the sculpt. The artefacts will become quite apparent when rotating the camera.

Richard Antalik (ISS) changed the task status from Needs Information from User to Confirmed.Tue, May 5, 11:21 AM

I can see this bug now. I guess it is best to try sculpting a cube and check sides after boulging a face.