Page MenuHome

undo in sculpt mode removes (delete) last edited mesh
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.66

Blender Version
Broken: version: 2.83 (sub 13), branch: master, commit date: 2020-04-16 15:38, hash: rB8cb10c124efe
Worked: (newest version of Blender that worked as expected)

Short description of error
I used undo (ctrl+z) on last smooth operation and all (I believe) evected by that operation faces were removed leaving a hole.

Exact steps for others to reproduce the error
I folowed tutorial on the cloudfor stylized character. I used remesher to join all geometry and started smoothing out the model. I think I used the crease tool with both crease and cut brush and than started to smoothing it out. I attached two saves, one before and one after bug.

Event Timeline

Artur (artur.machura) renamed this task from undo in sculptmode removes (delate) last edited mesh to undo in sculptmode removes (delete) last edited mesh.Apr 17 2020, 9:35 PM
Artur (artur.machura) created this task.

Well, It is wierd. It seems to be a graphic issue. I just opened the second file (11) and it looks OK. I am sure i didn't click H (if it even is posible to use "hide" in sculpt mode) instead ctrl Z, and if so the faces should be still hidden.

I just run a line accross the surface ( brush-cut) and click ctrl Z on the file (11)

Hey Artur

Please update the task description with steps to redo the bug, a bit more clearly. https://developer.blender.org/maniphest/task/edit/75846/

Ankit Meel (ankitm) renamed this task from undo in sculptmode removes (delete) last edited mesh to undo in sculpt mode removes (delete) last edited mesh.Apr 18 2020, 5:09 PM
Ankit Meel (ankitm) updated the task description. (Show Details)
Philip Holzmann (Foaly) changed the task status from Needs Triage to Needs Developer to Reproduce.Apr 18 2020, 5:19 PM

I can confirm that after using the "Cut"-brush (Crease), and then Undo, some faces turn green.
No faces are deleted.
Maybe this is related to face sets somehow?

@Artur (artur.machura) Could you elaborate on what you meant by "deleted"?
Did the faces just change color, or was there an actual hole in the mesh?

Image shows how it looked like when it happend for the first time. (maybe it is not fully accurate because I didn't do a screengrab at that time)

As a coment to the previous picture the green faces are the one that when I was working on the file have disapear. The green faces are the one I use cut and smooth in the first place and than undone last operation. In that moment there was a hole in location of green faces ( as shown on the photo sent now). I saved the file as it was and done the initial report. Than I reopened the file the faces were there, and were normal grayish. When I done randome cut and und undo I got the green faces as above. I was working on this project for few hours and I got green faces bug one more times but this time nothing disapeard.

Richard Antalik (ISS) changed the task status from Needs Developer to Reproduce to Needs Information from User.Apr 20 2020, 2:35 PM

@Artur (artur.machura) I think We will need steps to reproduce this issue. Are you sure you haven't accidentally drawn some face set?

I can confirm that after using the "Cut"-brush (Crease), and then Undo, some faces turn green.
No faces are deleted.
Maybe this is related to face sets somehow?

It behaves like face set. Can you share steps how to reproduce from scratch (or sculpt template)?

@Richard Antalik (ISS)
I was starting with the CLOUD CHARACTER TRAINING 11.blend.
I do not know of a way to reproduce it from scratch.

Ankit Meel (ankitm) closed this task as Invalid.May 2 2020, 3:52 PM
Ankit Meel (ankitm) claimed this task.

I do not know of a way to reproduce it from scratch.

Unfortunately without that it's very difficult to trace down a bug.
So please file a new report with them when you can reliably make a buggy file.

this bug seems related to the interaction of face sets and dyntopo, I managed to get it almost everytime in the thread that Philip just mentioned