Page MenuHome

After opening File explorer with export shortcut the window doesn't ignore the first click from selecting something behind it
Confirmed, LowPublicKNOWN ISSUE

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce RTX 2070 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 445.87

Blender Version
Broken: version: 2.90 (sub 0), branch: master, commit date: 2020-04-20 18:51, hash: rB55a2682348df
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-03-12 05:06, hash: rB375c7dc4caf4
Worked: (newest version of Blender that worked as expected)

Short description of error
After you open the file explorer and the first click you do will select an object behind the window if there is any. Annoying if you use selected objects to export. Seems to only happen if you use a shortcut to export to any file type. Couldn't reproduce with selecting file -> export -> any file type.
Edit: If there is no objects behind where you click you will deselect everything.

Exact steps for others to reproduce the error
With default scene. Short cut some export file type. File -> export -> filetype -> assign shortcut. hit the shortcut and if you click in the file explorer window where the default cube is you will select it.

Event Timeline

Julian Eisel (Severin) changed the task status from Needs Triage to Needs Information from User.Apr 21 2020, 6:58 PM

I tried this on both Linux and Win10, but it works just fine for me. Off hand I don't see what could be causing this either... maybe try if factory settings solve it?

I did more testing. I did factory reset. Assigned a shortcut key that is in mouse. This will select something behind the window. If i have a shortcut in keyboard then it will not select anything behind the window and works as intended.

Ankit Meel (ankitm) closed this task as Invalid.May 1 2020, 8:01 PM
Ankit Meel (ankitm) claimed this task.

. Assigned a shortcut key that is in mouse.

Closing as limitation then.
Practically, it's too obscure.

Julian Eisel (Severin) reopened this task as Confirmed.May 15 2020, 1:15 PM
Julian Eisel (Severin) triaged this task as Low priority.

I was able to recreate this on Windows, but not on Linux.

While the way to recreate this is indeed a bit obscure, in that people probably don't run into this often, I still prefer errors to not slip through because of that.

Ankit Meel (ankitm) removed Ankit Meel (ankitm) as the assignee of this task.May 15 2020, 1:16 PM

I was able to recreate this on Windows, but not on Linux.

While the way to recreate this is indeed a bit obscure, in that people probably don't run into this often, I still prefer errors to not slip through because of that.

I agree that this is very obscure. I appreciate this stance though. Hopefully i see this fixed at some point then.

@Julian Eisel (Severin) hi, a confirmed issue should always be tagged to a module, otherwise it is not considered triaged (and it doesn't show up in the corresponding queries/workboards). (in this case it wouldn't show up in the UI unclassified query).

https://wiki.blender.org/wiki/Process/A_Bugs_Life

Bastien Montagne (mont29) changed the subtype of this task from "Report" to "Bug".May 27 2020, 11:33 AM
Julian Eisel (Severin) changed the subtype of this task from "Bug" to "Known Issue".

I looked into this a while ago, but didn't find a simple solution. In favor of more high priority issues, I don't plan to look into this myself anytime soon again.