Page MenuHome

Armature slowing down FPS
Closed, ResolvedPublic

Description

System Information
Operating system: Darwin-19.3.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 560X OpenGL Engine ATI Technologies Inc. 4.1 ATI-3.5.5

Blender Version
Broken: version: 2.83 (sub 15), branch: master, commit date: 2020-04-29 19:35, hash: rBcd833d887995
Worked: 2.83 (sub 13), branch: master, commit date: 2020-04-13 08:07, hash: rB2ec6eca518ef

Short description of error
When playback is on the FPS goes down to 5 when the armature is visible. The same file works fine on a branch from a few days ago.

Exact steps for others to reproduce the error
Add a Monkey, subdivide by 3, apply.
Add a human meta rib, Generate Rigify Rig.
Select Monkey, the rig and Set Parent With Automatic Weights.
Enter Pose Mode, add keyframes for a short animation moving and rotating random bones.

Playback with the Armature visible then hide it and see the difference.
It works fine on the human rig without the Rigify "Generated Rig", so it might be related.

Event Timeline

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Needs Information from User.May 4 2020, 4:40 PM

I cannot reproduce this with either the latest stable or current development versions of Blender:

Please try the latest daily build: https://builder.blender.org/download/

Go to File → Defaults → Load Factory Settings and then load your file to see if you still can reproduce this issue.
If the problem persists, please give us more clear instructions on how to reproduce it from scratch.

Gabriel Moro (gabrielmoro) closed this task as Resolved.May 4 2020, 7:47 PM
Gabriel Moro (gabrielmoro) claimed this task.

It's 100% fixed now. Guess it was just from that specific release. :)