Page MenuHome

Blender 2.9 graphics wipes out desktop entirely, forcing me to reboot
Needs Developer to Reproduce, NormalPublicBUG

Description

System Information
Operating system: Linux-5.6.8-300.fc32.x86_64-x86_64-with-fedora-32-Thirty_Two 64 Bits
Graphics card: Mesa Intel(R) HD Graphics 630 (KBL GT2) Intel 4.6 (Core Profile) Mesa 20.0.5

Blender Version
Broken: version: 2.90 (sub 0), branch: master, commit date: 2020-05-02 04:12, hash: rB03b911dd8776
Worked: Blender 2.83 all builds

Short description of error
I'm using Gnome on X11, my Dell X15 laptop has intel gfx and nvidia gfx, with prime environments to switch. I was mistaken earlier (I think) - it seems the problem is restricted to the intel card.

When testing Blender 2.90 on my intel gfx card, eventually blender will *appear to* freeze, with some of the ui elements blinking (like the axis widget). When this happens, I can still see my mouse cursor but can't click on anything else. (I'm using the Gnome desktop environment) alt-tab / etc. don't work. so I can't do anything in the gui anymore. I tried ctrl-alt-F3 to go into a new tty (it worked) but ps -A doesn't seem to show blender on the running processes. going back to my session, it now appears black with a messed up cursor. I go back to the console tty and do a restart.

Exact steps for others to reproduce the error

  • In a setup like mine using prime nvidia / intel, start blender 2.9 without the nvidia environment variables
  • Use the annotation tool - this seems the fastest way for me to trigger the bug but it may be not the only way.
  • Blender stops responding seemingly and some interface elements (the navigation gizmo for example) starts blinking
  • The rest of the desktop interface is now not responding visually to mouse clicks, though the cursor is moving, and it looks ok (just static, but not much glitching)
  • ctrl alt F3
  • log into tty 3and ps -A
  • blender seems like it is still running
  • ctrl alt F1 - gdm looks ok
  • ctrl alt F2 , then alt F2 follwed by r (restart gnome shell) doesn't seem to work
  • my session is now totally black with a glitch cursor

Event Timeline

Ankit (ankitm) changed the task status from Needs Triage to Needs Information from User.May 4 2020, 8:34 AM

these index, config, faq, common problems pages might have a better solution than that workaround you're using.

Also if you built it from source, a git bisect can help narrow down the change that caused the problems. https://stackoverflow.com/a/37306623

I can't get it to happen again - not sure if the change is in my config or in blender, I'll mark as invalid untill it happens again , if it does.

bassam kurdali (bassamk) closed this task as Invalid.May 4 2020, 5:02 PM
bassam kurdali (bassamk) reopened this task as Needs Triage.May 5 2020, 7:17 PM

Ok I've opened it as I have more information
This is for now the better system information:
System Information
Operating system: Linux-5.6.8-300.fc32.x86_64-x86_64-with-fedora-32-Thirty_Two 64 Bits
Graphics card: Mesa Intel(R) HD Graphics 630 (KBL GT2) Intel 4.6 (Core Profile) Mesa 20.0.5

I launched blender not with the prime env variables but without (this is easy to do by accident since it's the default - I have to right click and choose a menu item to run on nvidia)
I triggered the problem using the annotation tool
I couldn't get the problem to happen on the nvidia card yesterday which is why I assumed it was 'fixed' or invalid. I think this is an intel driver problem.

Blender does not crash when the problem happens - this is what I observe:
tty1 (where gdm is running) looks fine
tty2 (my session) no longer is painting the screen properly, but it seems that it is working - just not outputing stuff to the graphics card
tty3 terminal session works fine. ps -A |grep blender shows it still running
Here's how it looks: right after it stops updating the screen:

Then, a quick trip to tty3 to see if the process is running:

Now back in tty2 (my session) just tried alt-F2 and r which restarts the gnome shell:

In order for us to investigate, we need to reproduce the problem.
Are you sure this only happens in this setup: Linux + Intel?

To work around the problem you can make Blender use the NVidia GPU instead of Intel's one.
You can see the GPU that blender is using in the system-info.txt generated with Help -> Save System Info.

Hi Germano,
Yes it is hard to reproduce! I'm not sure at all, it could be:

  • a problem on intel in general
  • a problem on fedora and/or gnome in combination with intel
  • only a problem when you have dual video cards?
  • only on X11

It's also quite random.

It does not seem to happen on the nvidia card (I thought it did but now I think I was just mistaken), Here's system info while launching from intel:

Also the laptop is a Dell XPS15:

Clément Foucault (fclem) changed the task status from Needs Triage to Needs Developer to Reproduce.Jul 2 2020, 3:27 PM
Clément Foucault (fclem) changed the subtype of this task from "Report" to "Bug".
Clément Foucault (fclem) moved this task from Backlog to Bugs on the EEVEE & Viewport board.

I haven't seen this for a while, and I don't know if it still happens (I switched my main machine to an nvidia only desktop) - I can test if needed.