Page MenuHome

Crash on saving rendered image if you close the child window which shows the rendered image
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 760/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.87

Blender Version
Broken: version: 2.83 (sub 15), branch: master, commit date: 2020-05-04 21:58, hash: rBd8133b3eb99a

Short description of error
blender crashes when you try to save a rendered image with pressing (Alt+Left Shift+S) than not saving it but switch back to the render showing window closing it switch back and than press Save as Image.) it crashes.

Exact steps for others to reproduce the error
open blender
from render menu select render image
press Alt+Left shift+S or select Save as image from image drop down menu
close render image showing window from taskbar and close it
switch back to the save as image dialog tab and press Save as image it the bottom.

Event Timeline

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Confirmed.May 6 2020, 4:32 PM
Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Bug".

I can confirm.

Exception thrown: read access violation.
hook was 0xFFFFFFFFFFFFFFFF.
>	blender.exe!BKE_workspace_active_get(WorkSpaceInstanceHook * hook) Line 413	C
 	blender.exe!WM_window_get_active_workspace(const wmWindow * win) Line 2342	C
 	blender.exe!WM_window_get_active_screen(const wmWindow * win) Line 2378	C
 	blender.exe!wm_handler_op_context(bContext * C, wmEventHandler_Op * handler, const wmEvent * event) Line 1649	C
 	blender.exe!wm_handler_fileselect_do(bContext * C, ListBase * handlers, wmEventHandler_Op * handler, int val) Line 2268	C
 	blender.exe!wm_handler_fileselect_call(bContext * C, ListBase * handlers, wmEventHandler_Op * handler, const wmEvent * event) Line 2374	C
 	blender.exe!wm_handlers_do_intern(bContext * C, wmEvent * event, ListBase * handlers) Line 2784	C
 	blender.exe!wm_handlers_do(bContext * C, wmEvent * event, ListBase * handlers) Line 2836	C
 	blender.exe!wm_event_do_handlers(bContext * C) Line 3231	C
 	blender.exe!WM_main(bContext * C) Line 453	C
 	blender.exe!main(int argc, const unsigned char * * UNUSED_argv_c) Line 530	C
 	[External Code]
Bastien Montagne (mont29) triaged this task as Low priority.Tue, May 12, 10:08 AM

@Germano Cavalcante (mano-wii) you'll have to explain to me what you see in that report and your backtrace that relates to data/IO? That's quiet clearly a UI (window management while modal operator is running?) issue...

Also weird things to do, would consider that as low priority, unless @Julian Eisel (Severin) has an idea?

There's code to NULL region and area references in modal-handlers to be freed, WM_event_modal_handler_region_replace() and WM_event_modal_handler_area_replace() we could probably do the same for windows here. Can't recreate on my current system (which doesn't have such a task-bar) so can't check the fix right away.

@Germano Cavalcante (mano-wii) you'll have to explain to me what you see in that report and your backtrace that relates to data/IO? That's quiet clearly a UI (window management while modal operator is running?) issue...

You're right. I must have confused wm_handler_fileselect_call as being an area of "file browser".

@Julian Eisel (Severin), I'll check this suggestion.

This is complicated.
Due to the number of references dependent on the window with the image, the simplest solution would be to either close the browser window together, or send an error message.

Julian Eisel (Severin) closed this task as Resolved.Fri, May 22, 10:17 PM
Julian Eisel (Severin) claimed this task.

I cannot reproduce this with latest master (but with earlier versions) and I'm quite sure it got fixed with rB796412dca0a5.
With this commit the file browser gets closed with the image editor.