Page MenuHome

Middle Mouse drag while in 3D view into node tree causes glitch
Needs Developer to Reproduce, NormalPublic

Description

System Information
Operating system: Darwin-19.5.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 555 OpenGL Engine ATI Technologies Inc. 4.1 ATI-3.9.13

Blender Version
Broken: version: 2.83 (sub 15), branch: master, commit date: 2020-05-08 14:49, hash: rBce76e17584ee
Worked: (newest version of Blender that worked as expected)

Short description of error
I am experiencing rendering GUI glitch while I am rotating in 3D view, and dragging middle mouse button up into node tree area. This does not always happen, but just to be aware.

Exact steps for others to reproduce the error

  1. Tumble around 3D view using Middle Mouse Button
  2. When mouse goes around node tree area, screen started to glitch while still dragging
  3. I record video:

VIDEO:
https://youtu.be/z96wsAqs6Ag

Very likely not easy to recreate this bug...

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.May 12 2020, 2:02 PM

enzyme69 Can you please share ewxample .blend file?

Also I assume that continuous grab has to be disabled un user preferences, is that correct?

Hi Richard,

Very likely not related to the blend. I am using default, not sure about "continuous grab", I am not changing anything in preference.

This might be related and the bug can be recreated. Something about dragging with MMB click drag and doing something while so.
https://youtu.be/2pjzrrKYxHY

By default when grabbing with MMB cursor should wrap around editor area. This shouldn't happen if you don't change user preferences.

Just to confim, click on FIle > Defaults > Load Factory Settings and check if this happens.

Ultimately there would be 2 bugs - one for incorrect grab behavior and second for glitches.

Are you using some non-standard mouse drivers?

We had similar sounding issues like this reported in the past: T39826: Panning or rotating viewport glitchy movement with SmoothMouse

Hi Campbel, I am not using non-standard mouse, it's a very basic 3 button mouse.

However I use MacBookPro and use track pad a lot too, like when using node tree, while middle mouse drag (hold press), I often accidentally swipe with my trackpad and switch to other app full screen, and this causes the glitch too. Suddenly node tree middle mouse become maxed out like it jumps like crazy.

Philipp Oeser (lichtwerk) changed the task status from Needs Information from User to Needs Triage.Jun 23 2020, 9:52 AM
Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Developer to Reproduce.Aug 5 2020, 1:37 PM

Also cannot reproduce. I think all information has been provided though, will set status to "Needs Developer To Reproduce"