Page MenuHome

[Mantaflow] mesh generation does not account for some particles
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: AMD Radeon HD 7560D ATI Technologies Inc. 4.5.13399 Core Profile Context 15.201.1151.1008

Blender Version
Broken: version: 2.83 (sub 15), branch: master, commit date: 2020-05-11 19:18, hash: rB8956e9e5f6c0
Worked: (newest version of Blender that worked as expected)

Short description of error
The mesh is not generated in areas that are in contact with the walls of the domain.

Exact steps for others to reproduce the error

  1. Open file
  2. Bake the liquid
  3. Set Physics properties > Mesh > Upres Factor = 6
  4. Bake the mesh

Particles don't fit in mesh. This doesn't happen if Physics properties > Mesh > Upres Factor = 1

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.EditedMay 18 2020, 12:02 PM

I can not confirm this in older or newer Blender version.

Please click on File > Defaults > Load Factory Settings and check if that will resolve this issue. Just make sure you re-bake particles and mesh.

I think I can see this effect with default cube afrer running quick liquid, but I am not sure if this is bug.

Edit after quich testing It seems that increasing Mesh Upres Factor will "offset" the mesh.

Richard Antalik (ISS) changed the task status from Needs Information from User to Confirmed.May 18 2020, 12:12 PM
Richard Antalik (ISS) updated the task description. (Show Details)
Jacques Lucke (JacquesLucke) changed the subtype of this task from "Report" to "Bug".May 19 2020, 2:50 PM