Page MenuHome

Mesh cage appears outside of Clipping Region in Edit mode in Material and Render preview
Confirmed, NormalPublicBUG

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.19

Blender Version
Broken: version: 2.83 (sub 17), branch: master, commit date: 2020-05-15 17:29, hash: rBe5ace51295b9
Worked: 2.81a

Short description of error
In Edit mode vertices/edges/faces appear outside of Clipping Region but can't be selected.

2.81a

2.83

Event Timeline

Cant redo:

  • OS: Linux 5.6.13-arch1-1
  • REV: ec86db82b0a6e01b94c9487953f81253d506a72a
  • GPU: GeForce GTX 1080

Tested 2.90 master & 2.82 release.

Could you try to redo this with factory settings?

Also unable to reproduce:
Linux-5.4.0-7626-generic-x86_64-with-debian-bullseye
GTX 1050 Ti 440.82

Blender versions:
2.82a
2.83 rBdfe8195dfe83 (2020-05-19 23:15)
2.90 rB4f622c9a080b (2020-05-19 22:32)

Along with the factory defaults test that @Campbell Barton (campbellbarton) suggested, are you also able to test updating your GPU drivers to the latest game ready driver from https://www.nvidia.com/Download/index.aspx

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.Wed, May 20, 10:25 AM
Philipp Oeser (lichtwerk) changed the subtype of this task from "Report" to "Bug".

Can confirm actually.

System Information
Operating system: Linux-5.5.13-200.fc31.x86_64-x86_64-with-fedora-31-Thirty_One 64 Bits
Graphics card: GeForce GTX 970M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 440.64
version: 2.90 (sub 2), branch: master, commit date: 2020-05-20 05:00, hash: rBec86db82b0a6

Having a clipping region defined in Solid Viewport Shading and going to Material Preview or Rendered will leave verts outside the previously defined region unselectable [but visible].
This is because the clipping region is disabled for Material Preview or Rendered [this is by design, see D6047 / rB7878adf49cff] - but suppose selection buffer is not updated?... Checking... [will also update my diver...]

GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 445.87

2.83 rBdfe8195dfe83 2020-05-19 23:15

I installed latest game ready driver and loaded factory settings. Same thing.

Was actually mentioned as TODO in rB7878adf49cff: DrawManager: Disable Clipping in material/rendered mode

There are a few areas in the tooling (select, projection painting) that still needs to be tackled after this patch.

@Jeroen Bakker (jbakker), @Clément Foucault (fclem): not sure this is accepted as Bug then?

Sorry, I missed a step. Yes, I can reproduce the issue. But like @Philipp Oeser (lichtwerk) said, this seems to be by design. I'll leave decisions on what to do with this report to the developers and other moderators.

I would accept it as a bug as noted in the patch there are areas mentioned that still needed to be updated.