Page MenuHome

The relationship between Edge crease sharpness and the Quality setting is not specified in the manual like it is in the 2.80 release notes.
Confirmed, NormalPublicTO DO

Description

Blender Version
Broken: version: 2.83 (sub 17), branch: master, commit date: 2020-05-15 17:29, hash: rBe5ace51295b9

Short description of error
I never used creases, because Blender do not have nonlinear and linear not help much. But today I tried, and it seems, currrent creases do not work properly too :(

Is there cases where I can see the difference between 0.57 and 0.8?

Event Timeline

I'm not a developer so I can't comment if this is a bug (seems like it). But to get better results, you can set your subsurface modifier quality to 6:

@Alaska (Alaska) thanks, it is really work.
At quality 8 it goes to .97.

Vyacheslav (hitrpr) closed this task as Invalid.Fri, May 22, 2:23 PM

Using a plane subdivide once in edit mode (to produce the center edge), bent at a right angle, and a subdivide modifier set to viewport = 7. Note: Further testing shows that the level of subdivision is irrelevant; even 1 works.

As @Alaska (Alaska) wrote, increasing the quality will increase the range that the edge crease setting has an effect.

QualityEdge crease stopping point
30.56
40.64
50.71
60.78
70.84
80.90
90.95
10full range

Tested using 2.90.2 8f21f867e715

As there is a setting specifically to control this effect, and it is documented (see the below links), I will close this report. EDIT: I was too slow. =)

https://wiki.blender.org/wiki/Reference/Release_Notes/2.80/Modeling
https://docs.blender.org/manual/en/dev/modeling/modifiers/generate/subdivision_surface.html

@Evan Wilson (EAW)
The first thing I did — read manual. And there is no mention of such effect. And no such table.
So i think, there should be some words about it in crease-section.

And this useful table too.

QualityEdge crease stopping point
Evan Wilson (EAW) renamed this task from Edge crease effect stucks at 0.57 to The relationship between Edge crease sharpness and the Quality setting is not specified in the manual like it is in the 2.80 release notes..Fri, May 22, 4:37 PM
Evan Wilson (EAW) reopened this task as Confirmed.
Evan Wilson (EAW) claimed this task.
Evan Wilson (EAW) updated the task description. (Show Details)

@Vyacheslav (hitrpr) I just made that table. I have a feeling that the values will be different for different topology, so I don't think it could be added to to the manual. I will test to confirm this later.

So i think, there should be some words about it in crease-section.

I agree, I'll work on this later today.

Christopher_Anderssarian changed the subtype of this task from "Report" to "To Do".Sun, May 31, 11:49 AM