Page MenuHome

eevee: mix holdout with transparent fails
Closed, ResolvedPublic

Description

mixing holdout with transparent in an eevee shader nodes behaves unexpected.

reproduce:
holdout and transparent in a mix node.

  • it looks like the transparent bsdf is blending into black while bekoming alpha-ed out.
  • the material blendmode is "alpha blend". but other material blendmodes dont work aswell.

on 0.5 mixed, the holdout is half there, as expected, but transparent looks like color(0.5,0.5,0.5,0.5)

solution?
i assume, its internally blending to color(0,0,0,0) but the transparent needs (1,1,1,n) to stay invisible, and in this case should be at color(1,1,1,0.5) when 0.5 mixed.
(since it seems to not use the alpha information internaly and, if my assumption is correct, holdout just is alpha and doesnt need its own color data)

  • so for the transition it might work correct if holdout takes rgb from the material to be mixed with.
  • or maybe give the holdout node an rgb input for mixing situations.

i hope that helps somehow :)

System Information
Operating system: Windows-10-10.0.17763-SP0 64 Bits
Graphics card: GeForce GTX 980M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.20

Blender Version
Broken: version: 2.83 (sub 17), branch: master, commit date: 2020-05-24 19:03, hash: rB0d0df683d983
Worked: nope, ...this is all just so new to eevee <3

Event Timeline

Richard Antalik (ISS) closed this task as Invalid.May 27 2020, 2:54 PM
Richard Antalik (ISS) claimed this task.
Richard Antalik (ISS) edited projects, added EEVEE & Viewport; removed Nodes, Eevee.

To my knowledge this is working as it is supposed - holdout shader will not "pass" any data through therefore it will be completely black. Unfortunately I am not able to provide "workaround" for this case, but please try asking on forums for help, or propose new features on appropriate portals.

Issue reported here is a request for modified/improved behavior and not a bug in current behavior. Closing as this bug tracker is only for bugs and errors.

For user requests and feedback, please use other channels: https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests
For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug

For help using Blender, please try one of the community websites: https://www.blender.org/community/

posted this on rightclick select.
i still think its a bug.
in cycles its working like it should and since cycles and eevee should behave more or less the same, i hope it actually valid.

Clément Foucault (fclem) reopened this task as Confirmed.May 28 2020, 3:47 PM