Page MenuHome

cloth object connected to 2 rigid bodies does not animate correctly
Closed, InvalidPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 388.13

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-03-12 05:06, hash: rB375c7dc4caf4
Also Broken in version: 2.90.0 Alpha, branch: master, commit date: 2020-05-29 18:08, hash: rB2ee94c954d67
And in: 2.83 (sub 17), branch: master, commit date: 2020-05-29 09:59, hash: rB1d2b89304ac3

Short description of error
Cloth Object pinned to 2 rigid bodies does not animate correctly

Exact steps for others to reproduce the error

  1. Open the attached SingleballoonAnimationBugReport.blend file{F8587541}
  1. Play the animation and notice that there is
    • an animated cube called "connector" which is a passive rigid body,
    • a sphere called "ball" which is an active rigid body
    • An empty object called 'Constraint' which has a rigid body constraint of type 'point' applied between the cube and the sphere
    • A cylindrical object called 'string' which has a hook modifier applied to it, to connect it's top most points to the sphere. The 'string' is parented to the cube.
  1. Go to scene properties and notice that the gravity has a positive value in z direction, which is the reason for the ball to try to float away rather than fall down.
  1. Select the string object -> go to physics properties and apply 'Cloth'. In the Cloth settings, under Collisions dropdown disable the Object Collisions checkbox.

Now when you play the animation the string object doesn't move. This is wrong because the string is now suppose to float away while being connected to the sphere from the top end.

  1. In the Cloth settings go to Shape -> in the Pin Group datafield select 'pinned' vertex group. Play the animation and notice that the 'String Object doesn't animate like a cloth.

If I remodel the 'String' object and repeat the steps the animation sometimes work correctly. But this is quiet annoying as I have come across this issue in other places where there is cloth simulation. My final intention is to create a bunch of these animations but it's very hard to do as it sometimes do not work as there seems to be an annoying issue with the cloth animation that only works sometimes and fail in other times.
Thanks!

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.Jun 2 2020, 1:00 AM

@Maduranga Jayamaha (Maduranga) This is quite complex file and steps. Is it possible to reduce number of elements and steps to minimum?

Maduranga Jayamaha (Maduranga) changed the task status from Needs Information from User to Needs Triage.Jun 3 2020, 8:37 PM
Maduranga Jayamaha (Maduranga) updated the task description. (Show Details)

@Richard Antalik (ISS) I have removed some unwanted models from the previous file and attached a simpler file. Also reduced the number of steps for developers to reproduce it by attaching a closer to complete .blend file.
However if i try to recreate this by remodeling everything from scratch, sometimes it works fine and sometimes not.
Thanks!

Richard Antalik (ISS) closed this task as Invalid.Jun 4 2020, 10:36 AM
Richard Antalik (ISS) claimed this task.

Thanks for new files. I have only now looked at console and saw that there are dependency cycles. You need to resolve these, otherwise simulations won't work correctly.

Dependency cycle detected:
  SCScene/Transform Component/RIGIDBODY_SIM() depends on
  OBConstraint/Transform Component/TRANSFORM_FINAL() via 'RigidBodyConstraint Transform -> RB Simulation'
  OBConstraint/Transform Component/TRANSFORM_SIMULATION_INIT() via 'Simulation -> Final Transform'
  OBConstraint/Transform Component/TRANSFORM_EVAL() via 'Transform Eval -> Simulation Init'
  OBConstraint/Transform Component/TRANSFORM_PARENT() via 'Eval'
  OBConstraint/Transform Component/TRANSFORM_LOCAL() via 'ObLocal -> ObParent'
  OBConstraint/Transform Component/TRANSFORM_INIT() via 'Transform Init'
  OBConnector/Transform Component/TRANSFORM_FINAL() via 'Parent'
  OBConnector/Transform Component/RIGIDBODY_TRANSFORM_COPY() via 'Rigidbody Sync -> Transform Final'
  SCScene/Transform Component/RIGIDBODY_SIM() via 'Rigidbody Sim Eval -> RBO Sync'
Detected 2 dependency cycles
Maduranga Jayamaha (Maduranga) changed the task status from Invalid to Resolved.Jun 6 2020, 7:46 PM
Maduranga Jayamaha (Maduranga) changed the task status from Resolved to Invalid.
Maduranga Jayamaha (Maduranga) updated the task description. (Show Details)

Hi @Richard Antalik (ISS),
I managed to remove the dependency cycles and still recreate the issue. However since it was not possible to reopen this task I created a new task which is https://developer.blender.org/T77529. Hope that it is OK to enter new task.
Thank you!