Page MenuHome

Dynamic weigth paint does not update density of particles in viewport display
Confirmed, NormalPublicKNOWN ISSUE

Description

System Information
Operating system: windows 10
Graphics card: Quadro M620

Blender Version
Broken: 2.90
Worked: Never

Short description of error
I want to use my dynamic vertex group to generate particles on a plane.
It just works when I change parameters during the playback but it's not realtime when I hit play.

Exact steps for others to reproduce the error

  • Open attached file
  • Play animation
  • Change any property of the particle during the playback

Event Timeline

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Confirmed.Jun 2 2020, 3:49 PM
Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Known Issue".

I tested it at 2.79 and 2.82, and it didn't work there.

This is the same root of problem as the T67394
Basically the density and position of each particle does not change with the modifiers updates.
This is intended to, for example, not redistribute hair on an animated character.
But in fact I don't see the need for this for non-hair particles.

This can be improved and there are plans to modify/redo the particle system.
For now I will mark this as a Known Issue.

Germano Cavalcante (mano-wii) renamed this task from blender 2.8 dynamic paint particles viewport display to Dynamic weigth paint does not update density of particles in viewport display.Jun 2 2020, 3:51 PM
Germano Cavalcante (mano-wii) updated the task description. (Show Details)