Page MenuHome

Full copy of a scene does not duplicate particle settings
Closed, ResolvedPublicTO DO

Description

System Information
Operating system: Linux-5.3.0-51-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 435.21

Blender Version
Broken: version: 2.83.0 Beta, branch: master, commit date: 2020-05-29 17:42, hash: rB691a1e3357e1, 2.90

Short description of error
Don't know if it's a bug or a feature. When you do a full copy you expect it to be a full copy, but particle settings rather stay linked.
And what's more, it should assign the copy of an instantiated object from the new scene. Well, I suppose it should work like that at least.

Exact steps for others to reproduce the error
Open the file.
Do Full Copy.
Particle settings stay linked.

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.Jun 2 2020, 2:09 PM

Not 100% sure this is by design, but would also expect this to get duplicated along...
(BKE_object_copy_particlesystems is actually called though, seems like ParticleSettings are not duplicated with this?)

CC @Bastien Montagne (mont29)

And what's more, it should assign the copy of an instantiated object from the new scene.

Would also agree on instance_object ideally being remapped, might be a feature request though (this might not be copied after all since it could be from some other scene).

Bastien Montagne (mont29) changed the subtype of this task from "Report" to "To Do".Jun 2 2020, 2:32 PM
Bastien Montagne (mont29) moved this task from Backlog to TODO's on the Pipeline, Assets & I/O board.

This is a TODO really, code is working as expected currently.

Think this full scene copy operation needs to be fully rewritten to use modern code and tools, and it should also use the same settings (in user preferences) as object copying itself, to decide which of its sub-data IDs it should duplicate alongside...

Bastien Montagne (mont29) closed this task as Resolved.Jun 10 2020, 7:47 PM
Bastien Montagne (mont29) claimed this task.