Page MenuHome

Full copy does not preserve collections checkboxes
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.3.0-51-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 435.21

Blender Version
Broken: version: 2.83.0 Beta, branch: master, commit date: 2020-05-29 17:42, hash: rB691a1e3357e1, 2.90
Worked: Never

Short description of error
Making full copy of a scene mess up enabled/disabled flags for collections in an unpredictable manner.

Exact steps for others to reproduce the error
Open the file.
2nd and 3rd collections are disabled and all of them are collapsed.
Make full copy.
Now only 3rd collection is disabled and all of them are expanded.

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Confirmed.Jun 4 2020, 10:58 AM
Richard Antalik (ISS) updated the task description. (Show Details)
Julian Eisel (Severin) closed this task as Resolved.Aug 4 2020, 1:09 PM
Julian Eisel (Severin) claimed this task.

There were some changes done to the scene copying lately, this seems to work now.

The issue with the copied enabled collection being expanded is still present. But that is by design of the Outliner code. Copying the scene data does not copy the UI data, these are separate things. New collections are expanded by default, after the copy this collection is new, hence it's expanded.