Page MenuHome

Glitch with several loose edges when changing Mask Modifier threshold
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1050/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.59

Blender Version
Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-06-08 15:55, hash: rB9f7d84b656fb
Worked: 2.83

Short description of error
The mask modifier in the 2.90 daily build appears visually while changing the threshold value.
A lot of random edges will appear on the masked object randomly.
These edges don't seem to have an effect on the rest of the modifier stack so it may just be visual.

Additional info
In the provided blend file there are 3 objects.

The first object has weights generated with a vertex weight edit modifier and a subsurf modifier before the mask.
The second object has manual weights and a subsurf modifier before the mask.
The third one has manual weights and no modifiers before the mask.

All three objects experience the glitches. This was to test that the glitches are not the result of a combination of modifiers.

Exact steps for others to reproduce the error

  1. Open the provided blend file.
  2. Select one of the objects.
  3. Use the mask threshold value to see the edges glitching as the value changes.

Revisions and Commits

Event Timeline

Jacques Lucke (JacquesLucke) changed the task status from Needs Triage to Needs Information from User.Jun 11 2020, 11:52 AM

Looks like you forgot to upload the .blend file.

Looks like you forgot to upload the .blend file.

Thanks. Fixed that.

Jacques Lucke (JacquesLucke) changed the task status from Needs Information from User to Needs Triage.Jun 11 2020, 12:47 PM
Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Confirmed.Jun 12 2020, 4:48 PM
Germano Cavalcante (mano-wii) triaged this task as High priority.
Germano Cavalcante (mano-wii) updated the task description. (Show Details)
Germano Cavalcante (mano-wii) renamed this task from Mask Modifier visually glitching when changing threshold to Glitch with several loose edges when changing Mask Modifier threshold.Jun 12 2020, 4:50 PM
Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Bug".
Jeroen Bakker (jbakker) closed this task as Resolved.Jun 16 2020, 8:03 AM

Tested that this issue has been fixed by the T77342