Page MenuHome

Displaying a large image impacts Image Editor and viewport modeling performance
Closed, ResolvedPublicKNOWN ISSUE

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce RTX 2060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.19

Blender Version
Broken: version: 2.83.0, branch: master, commit date: 2020-06-03 14:38, hash: rB211b6c29f771
Worked: 2.80

Short description of error
Displaying a large image in the Image Editor impacts performance, mostly in the editor's UI itself, but as well in viewports with certain modeling tools.
The behaviour is not consistent, but seems to occur in spikes. In my experience it's most noticeable with 4k+ images.

Exact steps for others to reproduce the error

  1. Load or create an image of several thousands of pixels (10K x 10K).
  2. Zoom out until you see whole image
  3. Play animation

The Image Editor's UI now exhibits a low frame rate and long response times.

Event Timeline

Just noticed that it only occurs when the image is at a zoom level of less than 100%.

Richard Antalik (ISS) changed the task status from Needs Triage to Confirmed.Jun 19 2020, 4:43 AM
Richard Antalik (ISS) updated the task description. (Show Details)

This goes to quite technical details of how image drawing works in Blender in general: every redraw will push the entire image to the GPU. For small images it's fine, but big images saturate the bus, causing lags.

Moving to the closest to the image drawing code module.

P.S. Technically this is a known limitation of current design.

Clément Foucault (fclem) changed the subtype of this task from "Report" to "Known Issue".Jul 1 2020, 2:26 AM
Clément Foucault (fclem) moved this task from Backlog to Long-Term on the EEVEE & Viewport board.
Jeroen Bakker (jbakker) closed this task as Resolved.Sep 11 2020, 4:37 PM
Jeroen Bakker (jbakker) claimed this task.

@Sam Van Hulle (sam_vh), This seems to be better in latest master, IMO good enough to close this issue.