Page MenuHome

Material names unreadable when linked from file with long name.
Closed, InvalidPublicBUG

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce RTX 2070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.19

Blender Version
Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-06-16 16:12, hash: rBefb1bf80dfc1
Worked: 2.83

Short description of error
Material names unreadable when linked from file with long name.
When i want to browse the linked materials i can´t read the names when the name of the linked file is too long.

Exact steps for others to reproduce the error

  • Link the material called "Material Test" from the attached file.
  • In the default cube, browse the materials to search for the "Material Test".
  • Compare the material name in blender 2.83 and 2.90.

Event Timeline

I confirm the above mentioned behaviour in 2.90 here on

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.92

Blender Version
Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-06-16 18:15, hash: rBc7b03fe9c07a
Worked: version: 2.83.0, branch: master, commit date: 2020-06-03 14:38, hash: rB211b6c29f771

The file name should be shortened as in 2.83. The width of the dropdown menu could be made resizable by the user so to allow the display of longer naming (material or file name)?

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Confirmed.Jun 18 2020, 4:32 PM
Germano Cavalcante (mano-wii) updated the task description. (Show Details)
Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Bug".
Julian Eisel (Severin) closed this task as Invalid.Jun 18 2020, 7:32 PM
Julian Eisel (Severin) claimed this task.

I expected there would be issues with this, there are two simple things I can see that we could do: 1. Increase the menu size, either for all cases or when there are library hints displayed, 2. force widget drawing to clip the right aligned, grayed out text, not the left one.

Anyway, this is not a bug, we're doing some design changes still. Created T78012 as an initial design task for this.

Even the version in 2.83.1 isn't usable in many cases. When you have an index at the end of the image file name (like "ThisGame_StoneTexture_Displacement_01.tif), you never see the "01" sometimes not even the "Displacement". 2.79 was fine as it didn't add the linked file name to the image file name.