Page MenuHome

UI: Search Menu Design for Linked Data-blocks
Closed, ResolvedPublicDESIGN

Description

[TODO this is so far just a quick task to have the information here.]

This task is mostly for the ID-template, but some of the design changes might work for regular search menus with data-blocks selected too.

  • We need an easily discoverable way execute operations on data-blocks, like "Make Local", "Add Library Override", "Delete Override", etc.
  • Could we show the library status (linked, overriden, missing), library name and user count info in or next to the search button, so users don't have to open the menu?
  • How to deal with cases where there's little space, like in more space-saving regions?

In 2.90 there were a couple of visual tweaks already, to make data-block management in production scenes simpler for search menus:

2.832.90

This design takes more space, so there are issues like T77929.

Event Timeline

Julian Eisel (Severin) changed the task status from Needs Triage to Confirmed.Jun 18 2020, 7:29 PM
Julian Eisel (Severin) created this task.

Nope, actually all mentioned points are still to be addressed.
(The plan for me is that I work on both, Asset Manger and Library Overrides UI throughout July.)

Julian Eisel (Severin) closed this task as Resolved.Dec 27 2020, 11:15 PM
Julian Eisel (Severin) claimed this task.

rB2250b5cefee7 addresses this sufficiently for now. With the exception of the space problems with the library name inside the menu. Opened a new task for that: T84188: Avoid clipping data-block name in data-block menu because of library name.