Page MenuHome

Hair drawing crash with NVIDIA GPU under macOS 10.15
Closed, ResolvedPublicBUG

Description

Starting with revision beef67d1, hair in the OpenGL viewport crashes on my Late 2013 MacBook Pro with NVIDIA GT750M graphics running macOS 10.15.This can be reproduced by launching Blender with the default cube and creating a hair particle system on it.

I am not aware of this happening on AMD GPUs and have no information about Intel GPUs.

Turning on the # define USE_TRANSFORM_FEEDBACK in draw_hair.c, line 44 for macOS appears to resolve the issue for me.

#0	  ___lldb_unnamed_symbol11655$$GeForceGLDriver ()
#1	  ___lldb_unnamed_symbol11656$$GeForceGLDriver ()
#2	  gpumGetTextureLevelInfo ()
#3	  gldGetTextureLevelInfo ()
#4	  glGetTexLevelParameteriv_Exec ()
#5	  gpu_texture_check_capacity at blender/source/blender/gpu/intern/gpu_texture.c:742
#6	  gpu_texture_try_alloc at blender/source/blender/gpu/intern/gpu_texture.c:761
#7	  GPU_texture_create_nD at blender/source/blender/gpu/intern/gpu_texture.c:914
#8	  GPU_texture_create_2d at blender/source/blender/gpu/intern/gpu_texture.c:1240
#9	  GPU_viewport_texture_pool_query at blender/source/blender/gpu/intern/gpu_viewport.c:384
#10	  DRW_texture_pool_query_2d at blender/source/blender/draw/intern/draw_manager_texture.c:141
#11	  DRW_hair_update at blender/source/blender/draw/intern/draw_hair.c:295
#12	  DRW_draw_render_loop_ex at blender/source/blender/draw/intern/draw_manager.c:1514
#13	  DRW_draw_view at blender/source/blender/draw/intern/draw_manager.c:1402
#14	  view3d_draw_view at blender/source/blender/editors/space_view3d/view3d_draw.c:1608
#15	  view3d_main_region_draw at blender/source/blender/editors/space_view3d/view3d_draw.c:1632
#16	  ED_region_do_draw at blender/source/blender/editors/screen/area.c:538
#17	  wm_draw_window_offscreen at blender/source/blender/windowmanager/intern/wm_draw.c:688
#18	  wm_draw_window at blender/source/blender/windowmanager/intern/wm_draw.c:809
#19	  wm_draw_update at blender/source/blender/windowmanager/intern/wm_draw.c:1012
#20	  WM_main at blender/source/blender/windowmanager/intern/wm.c:481
#21	  main at blender/source/creator/creator.c:532
#22	  start ()

Revisions and Commits

Event Timeline

Stefan Werner (swerner) changed the task status from Needs Triage to Confirmed.Tue, Jun 23, 8:56 PM
Stefan Werner (swerner) created this task.
Stefan Werner (swerner) updated the task description. (Show Details)
Ankit (ankitm) changed the subtype of this task from "Report" to "Bug".
Ankit (ankitm) added a subscriber: Ankit (ankitm).

It seems to go a bit further back than that. While simple scenes with hair (default cube) work, scenes like Fishy Cat were rendering wrong since cecda64e2ead502a052f9bea5ffde39e4a46bf90

Likewise, enabling USE_TRANSFORM_FEEDBACK on macOS in the latest master fixes the crashes with the default cube, but still crashes Fishy Cat.

Ankit (ankitm) closed this task as Resolved.Wed, Jul 1, 12:48 PM

rB8c4703127ad1: GPU: Apple/Nvidia Proxy check.