Page MenuHome

Sculpt Vertex color doesnt paint
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: Intel(R) HD Graphics 4000 Intel 4.0.0 - Build 10.18.10.5129

Blender Version
Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-06-24 21:51, hash: rBec776f18ff70
Worked: none

Short description of error
Sculpt vertex color doesn't work, it can load existing vertex color but doesn't paint and stores empty vertex colors

Exact steps for others to reproduce the error
Add a object
Switch to sculpt mode
Paint

Blend file used for this:

Event Timeline

I don't know if this is by design but I find that you have to choose to display vertex color instead of material under viewport shading to make it work. To make the painted color also show in rendered view, you have to go to shader editor and choose Input --> Attribute --> Name and enter the name of your sculpt vertex color and finally plug that into the base color of your shader.

Rahul Chaudhary (RC12) added a comment.EditedThu, Jun 25, 5:19 PM

I've tried that, the clip on the report is on vertex color display, it just doesnt paint, if it was painting and not just displaying the colors, it would store the color to vertex colors after clicking on the option instead of storing empty colors

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Needs Information from User.Thu, Jun 25, 7:37 PM

I cannot reproduce this with the current development versions of Blender: https://builder.blender.org/download/

Can you switch to Vertex Paint mode to see if the colors are actually being painted on the backgroud?

Go to File โ†’ Defaults โ†’ Load Factory Settings and then load your file to see if you still can reproduce this issue.

If the problem persists, please give us more clear instructions on how to reproduce it from scratch.

Rahul Chaudhary (RC12) closed this task as Resolved.Fri, Jun 26, 6:19 AM
Rahul Chaudhary (RC12) claimed this task.

Thank you! loading the factory defaults fixed the issue.