Page MenuHome

2.9 - editing cutter mesh wont affect boolean modifier in edit mode
Confirmed, NormalPublicBUG

Description

System Information 1:
Operating system: Linux-5.4.0-7634-generic-x86_64-with-debian-bullseye
Graphics card: GTX 1050Ti 440.82

System Information 2:
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1060 3GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 445.75

Blender Version:
Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-06-30 08:35, hash: rB55ae55af6646
Worked: 2.83.1

Short description of error:
This is a regression in Blender 2.90.0. In Blender 2.83.1 when a mesh is the subject of a boolean modifier, it can be modified in edit mode and the modifications can be seen in real time on the object with the boolean modifier. With Blender 2.90.0, the modifications made in edit mode do not show up on the object with the boolean modifier. They only show up after switching from edit mode back to object mode. Here's a video:

Exact steps for others to reproduce the error

  1. Create two objects and make sure they intersect in some way. I will call this objects Cube and Target.
  2. Select the Cube and give it a boolean modifier with the object Target as the reference mesh for the operation.
  3. Select Target and enter edit mode. In 2.83.1 you'll notice that Target still has an impact on the Cube while in edit mode while in 2.90.0 Target does not have an effect on Cube anymore while in edit mode (You may need to be in a wire frame mode to see it).

Here's a .blend file with steps 1 and 2 done.

Event Timeline

Richard Antalik (ISS) closed this task as Invalid.Mon, Jun 29, 6:42 PM
Richard Antalik (ISS) claimed this task.

I am not exactly sure why this modifier does not have option to show results in edit mode. I would guess that it is because with various modes it would be rather difficult to implement that because manipulating existing geometry can lead to it's modification. or in case of union, you would be able to modify geometry of other object?

In any case, thanks for the report, but the issue reported here is a request for modified/improved behavior and not a bug in current behavior. Closing as this bug tracker is only for bugs and errors.

For user requests and feedback, please use other channels: https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests
For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug

alexander (impacman) changed the subtype of this task from "Report" to "Bug".Tue, Jun 30, 8:59 AM

Hello

i dont really know how to change this task status, so sorry if i did wrong

let me describe this bug (yes, its bug, not request) in very precise way - in 2.9 at moment there is no switch "display modifier in edit mode" onto boolean objects as it ever was in blender before - i attached screen (left 2.8 right - 2.9)
and its absolutely not matter, which operation is performed - dif, union, inters,- boolean modifier now hasn t this switch as before did

Alaska (Alaska) changed the subtype of this task from "Bug" to "Report".Tue, Jun 30, 10:20 AM
Alaska (Alaska) added a subscriber: Alaska (Alaska).

@alexander (impacman) looking at Blender 2.79, 2.82a, 2.83.1 and 2.90.0, it seems the boolean modifier doesn't have a "display in edit mode" button when using the factory defaults (see below). The issue you're describing is a request to a change in behavior (the boolean modifier getting a display in edit mode button) or a issue with the add-on you're using.

Hope this helps.

Load factory defaults by selecting from the top of Blender File -> Defaults -> Load Factory Settings

i dont really know how to change this task status, so sorry if i did wrong

The option to re-open a task is limited to the moderators on this site.

alexander (impacman) changed the task status from Invalid to Resolved.Tue, Jun 30, 10:58 AM

okey, let me describe it in another words again (oh my...)

in 2.9 when you edit cutter of boolean object in edit mode its impossible to see end result onto boolean object

https://devtalk.blender.org/t/boolean-improvements/6200/86

alexander (impacman) changed the subtype of this task from "Report" to "Bug".Tue, Jun 30, 11:04 AM
alexander (impacman) renamed this task from 2.9 - boolean operations not interactive to 2.9 - editing cutter mesh wont affect boolean modifier in edit mode.Tue, Jun 30, 11:15 AM
Alaska (Alaska) reopened this task as Confirmed.Tue, Jun 30, 11:22 AM
Alaska (Alaska) edited projects, added Modeling, BF Blender (2.90); removed BF Blender.

Sorry, I was seeing two different things. I will try modify your original report to better explain the issue.

Alaska (Alaska) removed Richard Antalik (ISS) as the assignee of this task.Tue, Jun 30, 11:23 AM

Sorry, re-reading stuff I'm seeing all sorts of things I've missed. I'm sorry, today's just a weird day. I'll leave the handling of the rest of this task to someone else.