Page MenuHome

GPencil: Strokes Disappear at Certain Angles
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce MX130/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 451.48

Blender Version
Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-06-25 21:53, hash: rB62aa103d485f
Worked: (newest version of Blender that worked as expected)

Short description of error
I tried out the recently added "convert mesh to Grease Pencil", and I found out this issue, typically happens to long objects.

Exact steps for others to reproduce the error

Based on the default startup or download the attached .blend file if you want

  1. Scale the cube up along the X axis to make it long, so that it can be easier to observe
  2. Covert the cube to Grease Pencil
  3. Move the view closer and rotate around, at certan angle the strokes are going to disappear

P.S. In the attched .blend file I keyframed the camera so you can just hit the space bar to play and see it happens.



Event Timeline

Antonio Vazquez (antoniov) renamed this task from Grease Pencil Strokes Disappear at Certain Angles to GPencil: Strokes Disappear at Certain Angles.Fri, Jun 26, 8:38 PM
Antonio Vazquez (antoniov) changed the task status from Needs Triage to Needs Information from User.

This is not a bug. In your file, the edge of the stroke has only two points and when you put in some angles the stroke is clamped due the size of the edge. To solve, just subdivide the stroke and add more geometry and you can rotate without problem.

To solve, just subdivide the stroke and add more geometry and you can rotate without problem.

Thanks, it worked.

Zijun Zhou (Eary) closed this task as Resolved.Sat, Jun 27, 2:38 AM