Page MenuHome

Snap installation information missing from manual
Closed, ResolvedPublicTO DO

Description

At the moment the manual is missing installation and upgrade information for installing Blender through Snap on Linux. (https://docs.blender.org/manual/en/dev/getting_started/installing/linux.html)

Creating this task so it's on the work board. Also a simple task for a new user to pick up.

I also have no idea how snap packages work, so I'm probably going to leave this task to other users.

Event Timeline

Alaska (Alaska) changed the task status from Needs Triage to Confirmed.Sat, Jun 27, 5:37 AM
Alaska (Alaska) created this task.
Alaska (Alaska) edited projects, added Documentation; removed BF Blender.
Alaska (Alaska) changed the subtype of this task from "Report" to "To Do".
Alaska (Alaska) moved this task from Backlog to Missing documentation on the Documentation board.

Looks like a very nice and straightforward task for a new dev like me ๐Ÿ˜† .

I can write in directions for using snap on Linux, but the current manual seems to simply direct users to find out what package manager their distro supports and install it on their own. In general, that page seems rather sparse...

Would adding a section regarding a specific package manager be accepted?

Kenneth Y (Microbob) closed this task as Resolved.Sat, Jun 27, 10:26 PM
Kenneth Y (Microbob) claimed this task.

According to Tobias, the manual doesn't need to contain specific instructions for specific package managers unless there are special steps involved (which there isn't).

Please feel free to reopen if you disagree!

Also, in case you were wondering, to install Blender via Snap (assuming you've got Snap installed), the command is simply snap install blender --classic

I made a change in rBM6830. I want to include this information as snap is a little different than a package manager. The builds are also made by Blender and are more consistent with the official blender.org downloads.

hmm, I see. I didn't know that ๐Ÿ‘