Page MenuHome

VERY IMPORTANT AND URGENT THIS NEEDS TO BE FIXED
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: NVS 5400M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 392.59

Blender Version
Broken: version: 2.83.0, branch: master, commit date: 2020-06-03 14:38, hash: rB211b6c29f771
Worked: (newest version of Blender that worked as expected)

Addon Information
Name: Rigify (0, 6, 1)
Author: Nathan Vegdahl, Lucio Rossi, Ivan Cappiello, Alexander Gavrilov

ive been trying to import rigify into ue4 and so far it worked everything seems fun but the pain starts when i try to retarget the animation it seems that
def spine bones do not follow the org spine bones so if i would retarget the spine animation to the def spine bones the shoulders would be messed up and in the back because they are parrented to the org spine bones so why the heck not parrent the head and the neck bones to the org spine bones? atleast give me a way to do this manualy i need this to work very desperately

https://cdn.discordapp.com/attachments/225448446956404738/726769966082424832/unknown.png

please reply
contact me via email gloria.the.animator@gmail.com

Event Timeline

Robert Guetzkow (rjg) closed this task as Invalid.EditedSun, Jun 28, 4:51 PM
Robert Guetzkow (rjg) claimed this task.

This appears to be a feature request / feedback / user support question and not a bug in the add-on.

The bug tracker is unfortunately not the right place for improvement suggestions. For feature requests create a post on right-click select. If you're having trouble using Blender and need user support, please post a question on Blender's StackExchange, blenderartists.org, on the support channel of Blender's chat or one of the other community websites.

@Ivan Cappiello (icappiello) @Alexander Gavrilov (angavrilov) Feel free to reopen if you disagree.

@Gloria (GloriaTheAnimator),
As noted by @Robert Guetzkow (rjg) this sounds like a feature request. The bug tracker is not intended to be used like this.
That said afaik @Paolo Acampora (pkrime) is working on a basic solution to export rigify rigs in an as game friendly as possible way.
There are still some issues related to stretching that probably cannot be totally avoided but at least is a starting point.
Here’s the link:
https://github.com/pKrime/python-snippets/blob/master/blender_addons/rigify_convert_gamefriendly.py