Page MenuHome

Empties not Tranforming
Closed, ResolvedPublic

Description

System Information
Operating system: Win 8.1
Graphics card: Intel HD graphics 530

Blender Version
Broken: (2.82a,)
Worked: (newest version of Blender 2.83.1 has the same error now.)

The Empties on screen appear at the centre, but their physical locations are elswhere.

I was following this tutorial https://www.youtube.com/watch?v=K02hlKyoWNI&t=495s for camera to path. There was a shorcut Alt+G to centre and object. Since I did the same there was some disconnect between the empties on screen and their co ordinates. As in image the camera empties is visually at the centre but the camera frame is at the co-ordinates.

Same is for the light. It physically appears at centre while it's co ordinates are different.
The same goes for any future empty I create. It is very annoying. I have tried Blender reset and Re install but nothing is making this go away.

This was originally posted on Blender's StackExchange.

Exact steps for others to reproduce the error
Blender opens by default with this error.

Event Timeline

Robert Guetzkow (rjg) changed the task status from Needs Triage to Needs Information from User.Tue, Jun 30, 2:00 PM

This looks like the viewport drawing is not updating properly. Please open Blender, save the system information (Help > Save System Info) and upload them here by clicking on the upload icon or dragging and dropping the file.

Robert Guetzkow (rjg) updated the task description. (Show Details)

System info file is attached.

Please try to update your graphics driver and check if that resolves the issue. The current Intel driver for Intel® HD Graphics 530 can be downloaded here.

It worked guys, thanks a lot.

Robert Guetzkow (rjg) closed this task as Resolved.Tue, Jun 30, 4:41 PM
Robert Guetzkow (rjg) claimed this task.