Page MenuHome

Bump Maps not Displaying after Copying and Pasting Certain Object into Scene
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: Intel(R) Iris(R) Graphics 540 Intel 4.5.0 - Build 24.20.100.6299

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-03-12 05:06, hash: rB375c7dc4caf4

Short description of error
After copying and pasting the donut from the attached file into a new Blender file, any new objects with bump maps aren't displayed.

Exact steps for others to reproduce the error
Disclaimer: I am a Blender newbie so this may not be a bug.

Open a new Blender file. On the default cube object, go into the shading tab and in the node editor, attach a noise texture to a bump map and attach that to the normal component of the Principled BSDF (see image). Go to viewport shading and we should now see the bump map on the cube. (Behaviour is expected).

Now, open the file test.blend below. Copy and paste the donut object (ie Torus.001, Cube.001 and Cylinder) from this file into the new blender file we just created. Now retry the steps from before. Create a new cube object. Go into the shading tab and in the node editor, attach a noise texture to a bump map and attach that to the normal component of the Principled BSDF as before. Now go to the viewport shading and the bump map of the original cube is displayed, but the bump map of the new cube is not.

Saving and reopening the blender file does not fix the issue.

Intended behaviour: the second cube bump map is displayed along with the bump map on the donut.
Actual behaviour: neither the donut bump map or the second cube bump map is displayed.


Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.Wed, Jul 1, 1:12 AM

I can not reproduce this issue. Does this happen with latest development build? https://builder.blender.org/download/

Hi Richard,

The issue does *not* happen in the latest development build.

Cheers.

Bentley Carr (Yharooer) closed this task as Resolved.Wed, Jul 1, 3:32 PM
Bentley Carr (Yharooer) claimed this task.