Page MenuHome

Library Override crashes: saving a scene / editing the override / switching scenes
Closed, ResolvedPublicKNOWN ISSUE

Description

System Information
Operating system: Linux-5.4.44-1-MANJARO-x86_64-with-glibc2.29 64 Bits
Graphics card: AMD VERDE (DRM 2.50.0, 5.4.44-1-MANJARO, LLVM 10.0.0) X.Org 4.5 (Core Profile) Mesa 20.0.7

Blender Version
Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-07-03 17:12, hash: rB185fe9cd8bb1
Worked: 2.83

Short description of error
Blender 2.90 crashes on save if there is a library override and it crashes if the parameters of the library override are edited.
There is also another crash triggered by switching to a different scene

Exact steps for others to reproduce the error
Crash #1/#2 (save/edit)

  • link the material from the source file (File - Link - MAT_Source.blend - Materials - MAT_from2.90)
  • assign the linked material to the default cube
  • add a library override to the linked material (Outliner - Blender File mode - select linked material - Add Library Override via right-click menu)
  • try saving the project OR try changing a parameter like the color
  • crash

Crash #3 (scene switch)

  • steps 1-3 from above
  • create new scene (or switch to a different existing scene)
  • undo (so you are back in the original scene)
  • switch to a different scene
  • crash

Event Timeline

Georg K (georg) updated the task description. (Show Details)
Georg K (georg) renamed this task from Crash saving a scene with library override / editing the override to Library Override crashes: saving a scene / editing the override / switching scenes.Jul 4 2020, 12:20 AM
Georg K (georg) updated the task description. (Show Details)
Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Confirmed.Jul 7 2020, 9:30 PM
Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Bug".

I confirm the crash when trying to save the file.

Bastien Montagne (mont29) changed the subtype of this task from "Bug" to "Known Issue".

Overriding materials are not fully supported currently, nodes are as usual an issue... Will have a look though, should at least not crash

Bastien Montagne (mont29) closed this task as Resolved.Jul 8 2020, 6:13 PM

Fixed by rBe4926c167bac (yes, wrong commit message :( ).

Georg K (georg) added a comment.EditedJul 9 2020, 7:57 PM

Thanks! So basically you blocked using the override but not it's creation? Because while the testscenes do no longer cash, I still can't save my main project that already includes an overridden linked material (luckily, autosave does work).
Also

  • shift-clicking the material override icon of a linked material in the material properties editor
  • undo
  • shift-clicking the material override icon again

crashes blender (sometimes requires going back and forth multiple times).

backtrace:

# Blender 2.90.0, Commit date: 2020-07-08 16:08, Hash e4926c167bac
bpy.context.space_data.recent_folders_active = 0  # Property
bpy.context.space_data.context = 'MATERIAL'  # Property

# backtrace
/home/georg//blender-git/build_linux/bin/blender(BLI_system_backtrace+0x33) [0x3e4fea3]
/home/georg//blender-git/build_linux/bin/blender() [0xb4ddce]
/usr/lib/libc.so.6(+0x3c3e0) [0x7f998eb393e0]
/home/georg//blender-git/build_linux/bin/blender(BKE_lib_override_library_operations_create+0x1f) [0xb9927f]
/usr/lib/libtbb.so.2(_ZN3tbb10interface78internal20isolate_within_arenaERNS1_13delegate_baseEl+0x46) [0x7f9996181136]
/home/georg//blender-git/build_linux/bin/blender() [0x3e53863]
/usr/lib/libtbb.so.2(+0x2c705) [0x7f9996187705]
/usr/lib/libtbb.so.2(+0x2c9cc) [0x7f99961879cc]
/home/georg//blender-git/build_linux/bin/blender(BLI_task_pool_work_and_wait+0xe8) [0x3e53678]
/home/georg//blender-git/build_linux/bin/blender(BKE_lib_override_library_main_operations_create+0xf0) [0xb99740]
/home/georg//blender-git/build_linux/bin/blender(BKE_undosys_step_push_with_type+0x2e2) [0x1616872]
/home/georg//blender-git/build_linux/bin/blender(ED_undo_push+0x7d) [0x146945d]
/home/georg//blender-git/build_linux/bin/blender() [0x14bc478]
/home/georg//blender-git/build_linux/bin/blender() [0x148067d]
/home/georg//blender-git/build_linux/bin/blender() [0x1491605]
/home/georg//blender-git/build_linux/bin/blender() [0xe0435a]
/home/georg//blender-git/build_linux/bin/blender() [0xe049cc]
/home/georg//blender-git/build_linux/bin/blender(wm_event_do_handlers+0x4ff) [0xe0529f]
/home/georg//blender-git/build_linux/bin/blender(WM_main+0x20) [0xdfb8e0]
/home/georg//blender-git/build_linux/bin/blender(main+0x33e) [0xb2030e]
/usr/lib/libc.so.6(__libc_start_main+0xf2) [0x7f998eb24002]
/home/georg//blender-git/build_linux/bin/blender(_start+0x2e) [0xb4a34e]

Just found another crash:
In the outliner, in Blender File mode, select Copy in the right-click menu of an overridden data-block.

Please consider hiding library overrides under experimental features until it is more complete.

The copying crash is solved (version: 2.90.0 Alpha, branch: master, commit date: 2020-07-15 09:06, hash: rBe8b26a05018b), but the other isn't. It seems to crash more reliably with:

  • shift-clicking the material override icon of a linked material in the material properties editor
  • click the icon again (to make fully local)
  • undo
  • click the icon again (to make fully local)
  • crash

Should I file a separate report or does this belong to "known issue"?

Please create a new report yes, one issue per report. ;)