Page MenuHome

Mac crash with cycles and any mesh (T 78581 revisited with new video card)
Closed, ResolvedPublic

Description

System Information
Operating system: Darwin-17.7.0-x86_64-i386-64bit 64 Bits
Graphics card: NVIDIA GeForce GTX 980 Ti OpenGL Engine NVIDIA Corporation 4.1 NVIDIA-10.33.0 387.10.10.10.40.137

Blender Version
Broken: version: 2.90.0 Alpha, branch: master, commit date: 2020-07-09 17:04, hash: rB3623db7784b3
Worked: (newest version of Blender that worked as expected)

Short description of error
I reported a similar problem (T78581) and my report was deleted because the video card was outdated (ATI Radeon HD5770 )
I upgraded the video card to an Nvidia GTX 980 Ti but get the same result.
Any attempt to view on screen with Cycles and a mesh in the model causes instant crash.
The replacement video card comes within the list of supported video cards.
It works fine in 2.83 and is recognised as a CUDA enabled GPU.
It is NOT recognised as a CUDA enabled GPU in 2.9, however.
Is the list of supported cards changing and out of date?

Exact steps for others to reproduce the error
Open a new document add a mesh attempt to switch the viewport shading to Cycles... crash every time

Thanks for looking at this... Chris

Event Timeline

Robert Guetzkow (rjg) changed the task status from Needs Triage to Needs Information from User.EditedJul 10 2020, 5:18 PM

The NVIDIA GeForce GTX 980 Ti is a supported graphics card. Since you're still using macOS High Sierra (10.13.x) / Darwin-17.7.0 the driver is quite old, but I'm not aware of any changes that would stop it from being recognized on purpose, therefore this looks like a regression. (see comment by Brecht below)

Assuming the Blender 2.90 is installed to /Applications/Blender.app/Contents/MacOS/Blender, could you please open a terminal and run the following command to create a debug log in your home directory:

/Applications/Blender.app/Contents/MacOS/Blender --debug --debug-gpu > ~/blender_debug_output.txt 2>&1

Please try to make Blender crash again and attach the file to your bug report, as well as the crash log that macOS should create.

Regarding 2.90:
https://wiki.blender.org/wiki/Reference/Release_Notes/2.90/Cycles#GPU_Rendering

NVIDIA GPU rendering on macOS is no longer supported. Apple dropped support for CUDA drivers in macOS 10.14.

This comment was removed by Robert Guetzkow (rjg).

Not for CUDA rendering with Blender 2.90, that was dropped entirely.

@Brecht Van Lommel (brecht) Never mind, I was unaware that Blender dropped the CUDA support for all macOS versions in 2.90 due to Apple/Nvidia discontinuing the support for CUDA.

Robert Guetzkow (rjg) closed this task as Invalid.Jul 10 2020, 5:26 PM
Robert Guetzkow (rjg) claimed this task.
Brecht Van Lommel (brecht) reopened this task as Needs Triage.Jul 10 2020, 5:35 PM

The crash is still unexplained though.

@Christopher Hartley (chrisdesignart) While CUDA is no longer supported, could you please still run the command described in my first comment. This would help us identify the source of the crash.

As requested, I ran the debug script and have attached the bug report and the crash report.

I have to say I'm not thrilled to have just spent $600+ upgrading my video card only to be told you are now going to deprecate that, too!
The only need for the card was to be able to continue using blender past the 2.8x series.
You need to get this sort of info out there more quickly. The supported equipment list says that much older cards than mine are supported so I thought I was safe with this one.
...Chris

@Christopher Hartley (chrisdesignart) The situation with GPU rendering on macOS is unfortunately a bit complicated. Apple has deprecated their OpenCL compiler. Additionally they stopped using Nvidia GPUs in their products, which likely contributed to Nvidia's decision that CUDA-Toolkit 10.2 would be the last toolkit version to support macOS. This was announced in November 2019. I understand your frustration and indeed this could have been communicated better in Blender's roadmap for the development on macOS. Please note that Nvidia GPUs are still officially supported for running Blender, this "only" affects GPU rendering with Cycles.

The two workarounds I can think of at the moment is either a custom build with CUDA support (not sure if that is still possible) or using Boot Camp to run Windows on your Mac.

@Brecht Van Lommel (brecht) This practically means no Cycles GPU rendering support for Blender 2.90 on any macOS version. Is there anything we can tell users other than to wait for Metal/Vulkan support? Can technically experienced users on macOS prior to 10.15 still build Blender with CUDA support?

@Aaron Carlisle (Blendify) The GPU docs for 2.90 need to fixed, CUDA is still listed as supported on macOS.

Crash log looks like an issue with Embree and/or TBB.

So despite CUDA not being available for my GPU in 2.9 it SHOULD still run on my Mac?
The crash I get with Cycles and a mesh in a document is a bug?

As to Boot Camp and Windows... do I assume that this same GPU setup WOULD be supported if I run Blender that way?
Would Linux on the Mac be an option, too?

While inconvenient to reboot the machine between uses of Blender and my other software, if it allows me to stay up with the game while still using the power of my Mac's processors and memory it would be a useful interim measure. It seems that the only complete long term solution is to switch to a PC/Windows setup. In my case that comes with a heavy cost in terms of replacing my Mac software though.

...Chris

So despite CUDA not being available for my GPU in 2.9 it SHOULD still run on my Mac? The crash I get with Cycles and a mesh in a document is a bug?

Yes, Blender should still run on macOS 10.13 and your hardware. The crash you're having will be investigated and hopefully fixed.

As to Boot Camp and Windows... do I assume that this same GPU setup WOULD be supported if I run Blender that way?

The NVIDIA GeForce GTX 980 Ti is supported for GPU rendering on Windows and Linux. Disclaimer: I currently don't have access to Apple hardware, therefore I can't tell with certainty if the GPU works well on Windows when using Boot Camp (especially if it's an eGPU?). There may still be some pitfalls with driver support that I'm not aware of.

Would Linux on the Mac be an option, too?

Theoretically, yes. I haven't done this myself though and based on a cursory search this may require more tinkering than dual booting Windows. IMHO I would only recommend this for developers and people with tech experience.

It seems that the only complete long term solution is to switch to a PC/Windows setup.

When Blender gets Vulkan support in the future and thereby support for Apple's Metal API through MoltenVK (or even a native implementation for the Metal API), then it would be possible to have feature parity on macOS again.

@Brecht Van Lommel (brecht) @Stefan Werner (swerner) It seems that there are several people with similar issues on macOS:

I haven't merged them yet, because I can't verify if they have the same underlying cause (I don't have access to Apple hardware).

At first glance, looks like those are older Mac Pros crashing on illegal instructions inside Embree. Possibly Embree is detecting the CPU capabilities incorrectly? I don't have access to a Mac of that generation though. Maybe we need to run our own CPU detection and tell Embree explicitly what to use.

Sorry I'm not sure how this whole debug/revision system works but if I read this correctly there is a revision as yet untested on suitable hardware?
If so, am I able to test it for you on my Mac?
...Chris

Just to add, I have installed Blender 2.90 to my iMac (2014) with the same OS High Sierra 10.13.6 and everything runs fine.
It looks like that it is something related to the Mac Pro 2009 and 2010 that is causing the crash
Pier

@Christopher Hartley (chrisdesignart)

Sorry I'm not sure how this whole debug/revision system works but if I read this correctly there is a revision as yet untested on suitable hardware?

Yes, there is a patch in development that is not yet approved and thus not included in Blender.

If so, am I able to test it for you on my Mac?
...Chris

If you know how to build Blender yourself and how to use git to apply the patch, then you can test this yourself. Otherwise, you'll just have to wait until other developers have tested it, the patch is possibly revised based on feedback and once it is approved it will be included in Blender.

@Christopher Hartley (chrisdesignart) in addition to building Blender, you would have to build the updated OIDN library to apply all of the patch I believe. Either that or build without OIDN. As it involves a library update, I would personally wait until it is merged, and then test it out.

OK, sounds like I should wait :-)
Just thought I might be able to help as this particular blend of hardware may not be too avaoilable for testing on.
...Chris

Here's a test build with a potential fix:
https://download.blender.org/ftp/brecht/builds/blender-macos-simd-fix0.dmg

Can anyone test if it helps? I don't have the right hardware to test this.

@Brecht Van Lommel (brecht) Van Lommel (brecht)
Iv just tried on mc pro 5.1 os Mojave 10.14.6 amd WX5100 and render viewport and render still crashes on CPU.

My Blender still crash when set to render in Cycles
my system Mac 5.1
OS High Sierra 10.13.6

I'm afraid it is the same for me. Still crashes when I try to view or render in cycles.

MacPro 5,1 running OS 10.13.6 High Sierra on a SSD
2 x 6 core Intel Xeon processors running at 3.46GHz
96 Gb RAM
Nvidia GeForce GTX 980 Ti running three screens

...Chris

Official release tested on Macbook pro mid 2012 os catalina 10.15.5. Working!!!

Just tried and still crashes as before.
Anyway, thank you for the dmg.

I managed to reproduce this in a virtual machine and found an alternative fix. The 2.91 macOS build on https://builder.blender.org/download/ has the fix, please let me know if it doesn't work.

I managed to reproduce this in a virtual machine and found an alternative fix. The 2.91 macOS build on https://builder.blender.org/download/ has the fix, please let me know if it doesn't work.

Yupp.. Testing on my 2010 Mac Pro and now I can render happily. Both in viewport and Final 😃. Thank you..

Yes works on mine too.

Thank you! You guys are brilliant!

Pier

Me tooo!! Works. You changed my plans for weekend. My girlfriend will not like it. Thank you very much guys.
Jan

...and on mine!
Thanks for persevering, guys.
It is much appreciated
...Chris

I let you know that it works.
Thank you!

Regards
Giovanni