Page MenuHome

Segmentation fault when opening VSE files or displaying thumbnails
Closed, ResolvedPublic

Description

System Information
Operating system: Debian Bullseye
Graphics card: Radeon Vega 56

Blender Version
Broken: Blender 2.83.1 and Blender 2.82 (sub 7)
Worked: Blender 2.79b

Short description of error
When opening .blend VSE files, blender crashes with a segmentation fault.
Blender crashes both when called from the command line blender myfile.blendor when loading the file from blender.
Browsing (Shift-F1) to a folder containing a video also crashes Blender.

Content of the crash log

# Blender 2.82 (sub 7), Unknown revision

# backtrace
blender(BLI_system_backtrace+0x33) [0x563e281a10b3]
blender(+0x13e4dc6) [0x563e25bbbdc6]
/lib/x86_64-linux-gnu/libc.so.6(+0x3b800) [0x7f532422c800]
/usr/lib/x86_64-linux-gnu/libswscale.so.5(+0x74e6a) [0x7f5324a48e6a]

Exact steps for others to reproduce the error

  • Open blender
  • Browse (Shift-F1) to a folder containing a video
  • Change the display mode to "Thumbnails"
  • Blender crashes

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.Jul 13 2020, 7:16 PM

Can not reproduce this on windows. Can you check if this happens with portable build? https://builder.blender.org/download/

Also by VSE files you mean video files or .blend files with VSE projects?

Hello,

It doesn't crash with the latest build. Thanks.

By .blend VSE files I mean blender VSE projects.
The crash happens when Blender tries to display a video (avi, mp4…) thumbnail in the file browser. Almost all my VSE projects have a file browser in the layout, which must cause the crash.

In the meantime, it there a way I can disable thumbnails? Or open projects with an empty workspace?

Thanks.

You can change filebrowser to not display thumbnails this and save startup file.

I asked to check wih daily build, because crash occured in /usr/lib/x86_64-linux-gnu/libswscale.so.5 so this looks that there may be some problem in your system with this library. I am not sure what could be the issue, perhaps some application has overwritten this file with own that has some features missing? I am really just guessing now. That said, this may be a problem with package created by distro maintainers.

Perhaps you could also try to install via snap store?

Hello,

Changing the startup file doesn't help when loading existing projects does it? Or maybe I'm missing something.

I tried reinstalling libswscale just in case but it didn't help. Upgrading to the latest version in Debian Sid didn't help either.

Changing the startup file doesn't help when loading existing projects does it? Or maybe I'm missing something.

That is true, it won't help there.

@Sergey Sharybin (sergey) any idea what is the issue here?

Official Blender version do not use any system libraries other than X11 and OpenGL. They definitely do not use system-wide FFmpeg libraries (libswscale.so is part of FFmpeg).

We can only fix issues which we can reproduce with official builds from blender.org websites, and we do need exact files to reproduce the issue.

So:

  • Make sure issue happens with builds from blender.org / builder.blender.org
  • If the crash does happen with those builds, give an example of video file which makes thumbnails to crash
  • If some specific .blend file is needed for the crash, attach it as well

Exact same problem in my machine.

System Information
Operating system: Arch Linux
Graphics card: RTX 2070 Super

Please test with official builds from blender.org/builder.blender.org.
If the issue happens with the official builds, follow the bug report guidelines.

If the issue does not happen with the official builds, contact maintainer of Blender package in your Linux distribution.

Richard Antalik (ISS) closed this task as Invalid.Jul 17 2020, 1:41 AM
Richard Antalik (ISS) claimed this task.

I will close this report as this did not happen with official build

Please test with official builds from blender.org/builder.blender.org.
If the issue happens with the official builds, follow the bug report guidelines.

If the issue does not happen with the official builds, contact maintainer of Blender package in your Linux distribution.

The official builds work fine.
I am using them for the time being.

Thank you very much for your help!