Page MenuHome

Cannot bake normal map from dynamic paint using Workbench or any other render engine
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce RTX 2080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 451.67

Blender Version
Broken: version: 2.83.2, branch: master, commit date: 2020-07-09 05:50, hash: rB239fbf7d936f
Worked: (newest version of Blender that worked as expected)

Short description of error
Hi, I need to render a normal map sequence using Matcap/Workbench from dynamic paint simulation.
Basicaly the normal map is rendered but only the current frame, not considering the previous frames. I set on "Incremental".
In the Viewport the result is correct.
See attachment (blend file and video)

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline


Plese watch this wideo.

Thanx.
Andrea

You have to bake the cache for both particle system and dynamic paint before rendering to get proper results, this applies to all physics objects
It renders the sequence as expected after baking the simulations

This is not a bug, first you need to bake to get the results on render.
https://docs.blender.org/manual/en/latest/physics/baking.html#baking-physics-simulations

For help using Blender, please try one of the community websites: https://www.blender.org/community/

@Rahul Chaudhary (RC12) Thanks for explanation.

For help using Blender, please try one of the community websites: https://www.blender.org/community/

If you think you found a bug, please submit a new report and carefully follow the instructions. Be sure to provide system information, Blender version, and a .blend file with exact steps to reproduce the problem.