Page MenuHome

Vertex Normals Not Facing Correct Direction
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: GeForce GTX 1070/PCIe/SSE2

Blender Version
Broken: 2.83.2, branch: master, commit date: 2020-07-09 05:50, hash: 239fbf7d936f, type: Release

The vertex normals for this part are not aligned to the correct direction causing incorrect shading.

Exact steps for others to reproduce the error
I am unsure of the exact modelling steps that lead to this issue. However, the entire process was done in the aforementioned version of Blender.

The incorrect vertex normals seem to be linked to the object somehow. Adding a circle into the existing object and remodelling the part reproduces the exact same incorrect normals, but adding a new circle object, enabling smooth shading, auto-smooth normals and the mirror modifier, then modelling the part leads to a properly shaded object with correct normals.

Event Timeline

The object has abnormal scales, clearing them makes the cylinder large and flattened, and then scaling them to unflatten it and applying scales results in flipped normals which can be fixed with recalculating them. Flattening an object in edit mode and scaling it back in object mode gives the same issue, so I am not sure if this is a bug.
Edit : Checking back in older versions, all versions including 2.79 have this issue. Since older versions have the same behavior I am guessing this is not a bug.

Ah, didn't think that the issue would've originated from the scale. That would solve the issue then, doesn't appear to be a bug.

Richard Antalik (ISS) closed this task as Archived.Jul 22 2020, 6:11 AM
Richard Antalik (ISS) claimed this task.

I have noticed the scale, but haven't realized that it's quite weird considering object orientation. Thanks for suggesting to check this. This indeed looks like intended behavior.