Page MenuHome

Crash when Re-Rendering with EEVEE
Closed, ResolvedPublic

Description

System Information
Operating system: Darwin-18.7.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon R9 M370X OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.11.22

Blender Version
Broken: version: 2.90.0 Beta, branch: master, commit date: 2020-08-10 20:54, hash: rBbc5d144855d5
Worked: 2.83.4

Short description of error
This error occurs when trying to re-render a scene with EEVEE on MacOS 10.14.6.

Exact steps for others to reproduce the error

  1. Set up scene for rendering
  2. Render once
  3. Cancel mid-render
  4. Re-Render

Log:

Event Timeline

I tested it with current git. And I get an assert when rendering that scene for the first time. (I.E. no re-rendering needed for it to crash)

It shows the text:

Trying to draw with missing UBO binding.
Pass : , Shader : DRW_shader_create_with_shaderlib_120, Block : grid_block, Binding 1

and then aborts with the following stacktrace:

#0 GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50
#1 0x00007ffff77e0859 in
GI_abort () at abort.c:79
#2 0x000000000c225e2c in _BLI_assert_abort () at blender/source/blender/blenlib/intern/BLI_assert.c:50
#3 0x00000000038e674d in draw_update_uniforms (shgroup=0x7fffadcd9820, state=0x7fffb8493a50, use_tfeedback=0x7fffb8493a32) at blender/source/blender/draw/intern/d
raw_manager_exec.c:858
#4 0x00000000038e7cbf in draw_shgroup (shgroup=0x7fffadcd9820, pass_state=2147483650) at blender/source/blender/draw/intern/draw_manager_exec.c:1121
#5 0x00000000038e83af in drw_draw_pass_ex (pass=0x7fffadcfbae0, start_group=0x7fffadcd9820, end_group=0x7fffadcd9820) at blender/source/blender/draw/intern/draw_m
anager_exec.c:1295
#6 0x00000000038e84ff in DRW_draw_pass (pass=0x7fffadcfbae0) at blender/source/blender/draw/intern/draw_manager_exec.c:1336
#7 0x00000000039173b8 in EEVEE_volumes_compute (sldata=0x7fffcc8dc308, vedata=0x7fffc243d688) at blender/source/blender/draw/engines/eevee/eevee_volumes.c:750
#8 0x000000000390933e in EEVEE_render_draw (vedata=0x7fffc243d688, engine=0x7fffcc80e008, rl=0x7fffcc8fc688, rect=0x7fffb8493e30) at blender/source/blender/draw/e
ngines/eevee/eevee_render.c:587
#9 0x00000000038f3ee2 in eevee_render_to_image (vedata=0x7fffc243d688, engine=0x7fffcc80e008, render_layer=0x7fffcc8fc688, rect=0x7fffb8493e30) at blender/source/
blender/draw/engines/eevee/eevee_engine.c:543
#10 0x00000000038dad8c in DRW_render_to_image (engine=0x7fffcc80e008, depsgraph=0x7fffcc755a08) at blender/source/blender/draw/intern/draw_manager.c:1783
#11 0x000000000a7abc56 in RE_engine_render (re=0x7fffba150c08, do_all=0) at blender/source/blender/render/intern/source/external_engine.c:880
#12 0x000000000a7bce5b in do_render_3d (re=0x7fffba150c08) at blender/source/blender/render/intern/source/pipeline.c:1136
#13 0x000000000a7bd1a1 in do_render (re=0x7fffba150c08) at blender/source/blender/render/intern/source/pipeline.c:1213
#14 0x000000000a7bd71d in do_render_composite (re=0x7fffba150c08) at blender/source/blender/render/intern/source/pipeline.c:1353
#15 0x000000000a7be41e in do_render_all_options (re=0x7fffba150c08) at blender/source/blender/render/intern/source/pipeline.c:1613
#16 0x000000000a7bf58a in RE_RenderFrame (re=0x7fffba150c08, bmain=0x7fffbd7f6108, scene=0x7ffff0719808, single_layer=0x0, camera_override=0x0, frame=1, write_still=false) at /home/martijn/progs/
blender-git/blender/source/blender/render/intern/source/pipeline.c:2013
#17 0x000000000593bb34 in render_startjob (rjv=0x7ffff0761388, stop=0x7fffcda70884, do_update=0x7fffcda70882, progress=0x7fffcda70888) at blender/source/blender/ed
itors/render/render_internal.c:642
#18 0x00000000036014af in do_job_thread (job_v=0x7fffcda70808) at blender/source/blender/windowmanager/intern/wm_jobs.c:395
#19 0x000000000c2de8f7 in tslot_thread_start(void*) (tslot_p=0x7fffba45c008) at blender/source/blender/blenlib/intern/threads.cc:226
#20 0x00007ffff7f49609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#21 0x00007ffff78dd103 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

I hope this added information is useful...

I can't reproduce the crash or the assert.

Please try the latest daily build: https://builder.blender.org/download/

Go to File → Defaults → Load Factory Settings and then load your file to see if you still can reproduce this issue.


Operating system: Windows-10-10.0.18941 64 Bits
Graphics card: Radeon (TM) RX 480 Graphics ATI Technologies Inc. 4.5.13596 Core Profile Context 20.10.19.02 27.20.1019.2002

I can reproduce the issue using the latest daily build (2.90, August 11). It renders fine once, but crashes the second time. I'm just rendering the default cube. It seems that this might be a MacOS exclusive issue.

OS: Macos 10.13.6 High Sierra
Graphics: Intel HD Graphics 6000 1536 MB

Reproducing the issue with the latest build has failed. Problem seems to be patched!

Thearavid Sea (PhlixFer) closed this task as Resolved.Aug 13 2020, 11:19 AM
Thearavid Sea (PhlixFer) claimed this task.

I don't think it is patched because it still crashes here (linux, intel graphics, git build of blender). with the following output:

      Shader Compilation Log : MAVol

  122 |   dataAttrOut.var0 = dataAttrIn[vert].var0;
      |                      ^
      | Error : unsized array index must be constant



Linking Error:

error: fragment shader input `slice' has no matching output in the previous stage
Writing: /tmp/Desert_Crystal_1.crash.txt