Page MenuHome

Crash AMD video cards, closes \ hangs
Closed, DuplicatePublic

Description

System Information
Operating system: Win10
Graphics card: Asrock Radeon RX5700XT

Blender Version
Broken: (example: 2.80 and +, edbf15d3c044, master, 2018-11-28, as found on the splash screen)
Worked: (Nothing)

Short description of error
During real-time rendering, the blender closes on any version of the program, initially I had a "MSI RX460 2 GB", now I bought a "RX5700XT" but the problem has not changed, it was on both devices. the blender just closes or hangs. Sometimes it closes during normal rendering ... I can't work, and I don't understand what the problem is, at first I thought that Eve and Cycles are poorly compatible with AMD video cards, installed Radeon ProRender, which is adapted for them, but alas, the same trouble. .. I do not know what is the cause of the error, I cannot identify it for a long time.

Exact steps for others to reproduce the error
I found one option when the program freezes exactly, you need to enable real-time rendering of Cycles, Prorender, Eve \ set the checkbox to work in the CPU + GPU render and continue working. Very often freezes in this mode.

Event Timeline

Richard Antalik (ISS) closed this task as Invalid.Fri, Aug 28, 6:47 AM
Richard Antalik (ISS) claimed this task.

Prorender isn't maintained by Blender foundation. Please report this bug here https://community.amd.com/community/prorender/blender

OK thanks! What about Cycles?

Later I will try to make a video with a link.

If this crash happens with default settings(without addons), it can be bug in Blender. You can click on File > Defaults > Load Factory Settings

I judged this by report description where you wrote:

you need to enable real-time rendering of Cycles

Cycles does not have this option without addon as far as I am aware.

It seems that you are not competent, or we do not understand each other. Back in 2.79, Cycles had this mode, in 2.8+ it is called by holding down Z

@Pawal (BelCGFree) No need to call someone names. Please keep the discourse civil. You're referring to the Rendered option for Viewport Shading.

@Robert Kirberich (robert) Guetzkow
Yes, that's right. I didn't think it could be attributed to impoliteness, well, thanks for your interest.

In general, I do not like that my topic was closed before they sorted out the problem! I wrote about all render engines, not just the ProRender! ...

Robert Guetzkow (rjg) reopened this task as Needs Information from User.Sun, Aug 30, 12:08 AM

Please open Blender's installation directory and double click on the blender_debug_gpu.cmd. This will start Blender in debug mode and create log files. Try to make Blender freeze again and then close the application. Once Blender is terminated Windows Explorer should open and show you two files. Add them to your bug report by clicking on the upload button as shown in the screenshot below.

Robert Guetzkow (rjg) updated the task description. (Show Details)

@Pawal (BelCGFree) Please also add the affected Blender version(s) to your bug report as well as versions that did work properly, if one exists.

In general, I do not like that my topic was closed before they sorted out the problem! I wrote about all render engines, not just the ProRender! ...

Sorry about that, I think I had done bad research here. I assumed that ProRender does introduce "real-time rendering" option. I have little experience with pre-2.8 Blender versions.
Do you have any reference to where I can find this option? I can't find it even in manual for 2.79. Or do you mean openGL render?

I am not sure what your GPU driver is, I would recommend to update to latest version. This information would be auto filled in the report when you click on Help > Report a Bug in Blender. Please update it. There are some open reports with RX5700 involving crashes and glitches. See T75319, T65924, T80173. Please check if what you reporting is already reported there.

Please check if crash happens when you click on File > Defaults > Load Factory Settings and repeat steps to reproduce the error. This is to check if crash could be caused by an addon.
Be sure to test latest stable build https://www.blender.org/download/
And latest development builds https://builder.blender.org/download/

@Richard van der Veen (richard) Antalik
Thanks for the answer! Yes, the default settings work, but Cycles still crashes. Now I don't have much time to make a video, maybe closer to the weekend I will try, and yes, thanks for the help, I will definitely clarify and unsubscribe! After restoring the default settings, Render Pro started to work better, but Cycles did not...

Ok, I could probably look into prorender, because I am not sure if it is only addon or some kind of engine that is still working after factory settings, because it should be disabled by that.

In general we don't accept reports that report bug in modified B lender, only "vanilla" unless it is reasonable to expect, that bug is in Blender itself. So it is recommended to alway test if bug is in unmodified Blender without addons and also report from such version and build.

@Richard van der Veen (richard) Antalik But the inclusion of Cycles addon is not standard? Try with Eve?

@Pawal (BelCGFree) Please add the information requested in my previous comment.

@Pawal (BelCGFree) Cycles "addon" is standard. Just click on File > Defaults > Load Factory Settings before testing, that will unload all non-default addons.

Also My handle here is @ISS. Richard van der Veen must be quite annoyed about this :)

Pawal (BelCGFree) added a comment.EditedSun, Sep 13, 9:01 PM

Здравствуйте! Спасибо за встряску и внимание! Работа, был занят другими делами, прошу прощения... В общем ситуация такая! Я записал видео процесс, сбросил настройки по умолчанию, и в стандартной сцене проводил тест, в итоге серый экран во время рендера сцены с кубом, в дальнейшем при переключении рендера или отключении идет зависание, сначала я не знал как достать Debug файлы потому что после закрытия файлы не отображались. Я закрыл с помощью диспетчера задач, и покажу вам что получилось в файлах. Это наглядное(Быстрое) видео, задержка зависания думаю бесконечно , я ждал 10 минут...А видео переделал, покороче. Вылетов из программы пока не было, но я думаю это из-за того что не рабочая сцена, я думаю что были конфликты с материалами, т.к файл создавался в какой то из версий 2.8.0 . Видео записано на версии 2.8.5 LTS.

Hello! Thanks for the shake-up and attention! Work, I was busy with other things, I beg your pardon ... In general, the situation is like this! I recorded the video process, reset the default settings, and conducted a test in the standard scene, as a result, a gray screen during the rendering of the scene with the cube, then when switching the render or disconnecting it freezes, at first I did not know how to get Debug files because after closing files were not displayed. I closed it using the task manager, and I'll show you what happened in the files. This is a visual (Fast) video, I think the freezing delay is endless, I waited 10 minutes ... And I redid the video, shorter. There have been no crashes from the program yet, but I think this is due to the fact that it is not a working scene, I think that there were conflicts with materials, because the file was created in some version 2.8.0. The video was recorded on version 2.8.5 LTS.

https://youtu.be/Dfv9dqaA34k

На этом видео я показываю тоже самое, только сначала с работой рендера с помощью CPU.
Так же после зависания , прикрепил файлы. Постараюсь вызвать автоматическое закрытие программы, как это было раньше, но обычно это было во время рендера F12, либо после зависания.

In this video, I show the same thing, only first with the rendering work using the CPU.
Also, after freezing, I attached files. I will try to cause the program to close automatically, as it was before, but usually it was during F12 rendering, or after freezing.

https://youtu.be/mY-bdVqCZh8

In general, I do not like that my topic was closed before they sorted out the problem! I wrote about all render engines, not just the ProRender! ...

Sorry about that, I think I had done bad research here. I assumed that ProRender does introduce "real-time rendering" option. I have little experience with pre-2.8 Blender versions.
Do you have any reference to where I can find this option? I can't find it even in manual for 2.79. Or do you mean openGL render?

I am not sure what your GPU driver is, I would recommend to update to latest version. This information would be auto filled in the report when you click on Help > Report a Bug in Blender. Please update it. There are some open reports with RX5700 involving crashes and glitches. See T75319, T65924, T80173. Please check if what you reporting is already reported there.

Please check if crash happens when you click on File > Defaults > Load Factory Settings and repeat steps to reproduce the error. This is to check if crash could be caused by an addon.
Be sure to test latest stable build https://www.blender.org/download/
And latest development builds https://builder.blender.org/download/

Да, спасибо за ссылки на схожие проблемы, но всё сходится к тому, что выхода нет, кто то говорит ошибка Блендер, кто то говорит ошибка драйвера АМД...На данный момент я устанавливаю РадеонПРоДрайвер, буду пробовать...Так же видно, что проблема так же присутствует и на Нвидиа аппаратуре...И даже под Линукс, манджаро..господи я устал...)

Yes, thanks for the links to similar problems, but it all comes down to the fact that there is no way out, someone says Blender error, someone says AMD driver error ... At the moment I'm installing RadeonPRODriver, I will try ... that the problem is also present on Nvidia hardware ... And even under Linux, manjaro ... God, I'm tired ...)

Robert Guetzkow (rjg) changed the task status from Needs Information from User to Needs Triage.Sun, Sep 13, 10:50 PM

Thanks for screen recording, since you are using viewport render, this is the same issue as in T75319. I will merge this report so you will be notified of it's status

Just in case, I also want to add a log related to the crash during Cycles rendering, but I found it! You don't need to do anything special, just wait for the render preparation in the corresponding window after pressing F12. Long, 5-15 minutes gray boxes and then a miscarriage from the program.

Render settings :

Logs: