Page MenuHome

Objects deleted in outliner but exist in the scene
Closed, InvalidPublic

Description

System Information
Operating System> Windows 10
Motherboard> AS Rock Fatality H270 Performance
Processor> Intel Core I7-7700k 4.2Ghz
Ghraphics Card> Nvidia GTX 2070 SUPER 8GB
RAM> 32GB VIPER DDR4

Blender Version
Broken: 2.9

I apologise if this is not helpful but since its what I would call a massive bug (I think) i need to report it

After blender crashed my project I tried to reopen the project again but trying to open the save just crashed blender immediately thought it as a corrupt save so i backtracked to old ones and 50+ saves would not open I eventually opened the saves threw trial and error but Blender for some reason I have no idea why or how deleted my mesh and armature from the outliner I don't know how or why it happened but it no longer existed although it did exist in the scene which is very weird no amount of appending, importing or copy pasting fixed this every time I would try to open the project file it would crash if I tried copy pasting it from one file to another it would crash Its as if there was no data on either object even though I could edit the mesh and armature and make changed as I pleased. its very weird and the biggest bug i have encounter with blender up to now but I just scrapped my project and moved on since i was just learning sorry if this is of no help to you and your development team.

thank you for your continued development of such an awesome software ;3

Exact steps for others to reproduce the error Sorry im not sure how it happened in the first place
Based on the default startup or an attached .blend file (as simple as possible). sorry I also deleted the entire project

Event Timeline

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Needs Information from User.Sep 8 2020, 3:32 PM

Thanks for the report.

Some users have reported a similar problem with corrupted meshes.

We are aware of this problem but unfortunately unless there are clear instructions on how to reproduce it from scratch we cannot debug this any further.

Did you use any addons to import the mesh? Do you remember what may have happened right before the first crash?

Things that may cause mesh corruption: Importers, development versions of Blender, modeling tools.

Yeah I was not sure if it would help.

I'm sorry since the first crash happened after the mesh became corrupt and i didnt notice it till blender crashed I have no idea what caused it since all i was doing at the time was learning weight painting.

so I was just connecting my armature to my mesh and weight painting bones to get better bends

I made the mesh from scratch it was a quickly made mesh for learning.

The only addons I have that are not default blender off the top of my head are SSGI (Screen Space Global Illumination), Boxcutter and fspy importer

Im sorry I carnt be of any more help

Thanks for the info.
I will keep in mind what was mentioned.
Unfortunately we still don't have enough information to confirm the bug.