Page MenuHome

Multiple Frame Rates/ Playback/ VSE scene strips
Confirmed, NormalPublicKNOWN ISSUE

Description

System Information
Operating system: windows 10
Graphics card: rtx 2060

Blender Version
Broken: 2.90.0
Worked: Never

Short description of error
I'm using the VSE and I have 2 scene strips from two different scenes inside the VSE.
The first scene strip references a scene that is set to 12 FPS.
The second scene strip references a scene that is set to 24 FPS.
The 3rd scene is where I'm using the VSE, and this scene is set to 12 FPS.

The problem is, all the scene strips are playing back at 12 FPS by default in the scene where I'm using the VSE. In other words, the scene that is 24 FPS is playing back at 12 FPS.
If I'm not mistaken, this wouldn't happen with real footage. Two recordings with two different FPS dropped into a project would play back at different speeds.
What I'm trying to do is have a video at 12 fps, and the put a 24 fps scene strip in the VSE so that i can put it in slow motion and have it play back with the same quality.

Exact steps for others to reproduce the error

  • Open attached file
  • Run VSE

Note that the cube shown on each strip has the same speed in the animation.
It was expected that one was twice as fast than the other.

Related Objects

Event Timeline

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Confirmed.Thu, Sep 10, 4:13 PM
Germano Cavalcante (mano-wii) updated the task description. (Show Details)
Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Bug".

In fact, since FPS is a property of the scene, it is to be expected that the FPS of the VSE scene does not overwrite the expected frame for the other scenes' strip.
Maybe there should be a kind of multiplier to evaluate which frame of the other scene to computate.

I am confirming it as a bug, but there may be some limitations to achieving this, and it almost fits as a request for improved behavior (which is not accepted as a bug).
The final decision will be with the VFX & Video team

Richard Antalik (ISS) changed the subtype of this task from "Bug" to "Known Issue".Fri, Sep 11, 1:41 AM

In fact, since FPS is a property of the scene, it is to be expected that the FPS of the VSE scene does not overwrite the expected frame for the other scenes' strip.

True, but currently VSE does not support strips with different playback rate.

This is technically feature request but it should be covered by T59540. So it is "TODO". To change playback rate of strip please use Speen Control effect strip.