Page MenuHome

X-Ray effects only armature in pose mode
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 451.67

Blender Version
Broken: version: 2.90.0, branch: master, commit date: 2020-08-31 11:26, hash: rB0330d1af29c0
Worked: (newest version of Blender that worked as expected)

Short description of error
While editing an armature in pose mode x-ray will have no effect on other objects.
So only the armature whil be transparent, making x-ray in pose mode pretty much useless.

Just realized that x-ray has to be enabled in object mode before going into pose mode.

*Steps to replicate

  1. Enabel x-ray in object mode
  2. Select armature and go into pose mode
  3. enable x-ray

Event Timeline

That is not a bug, its a feature, but I think the option shouldn't change when entering pose mode, it's really inconvenient sometimes.


you can still activate object xray here, and if you want you can add it in the quick favorites.

Haven't seen that.
Thank you.

Vladislav (BoomRaccoon) closed this task as Resolved.Sep 14 2020, 11:54 AM