Page MenuHome

Texture Coordinate's Generated mapping differs on Intel and NVidia/AMD
Closed, InvalidPublic

Description

The problem is that Texture Coordinate node Generated output differs from Intel and NVidia/AMD GPU renders.

This is how it looks on Intel iGPU

This is how it looks on NVidia/AMD GPU

Steps to reproduce:
(This scene was rendered in Eevee but I'm not sure if it's related)

  1. Open default scene
  2. Go to shading to change the default cube's material
  3. Add Texture Coordinate and Noise nodes
  4. Plug Texture Coordinate's Generated into Noise's Vector
  5. Plug Noise's Fac into BSDF's Base Color

  1. Go to the default layout

This is where the bug should appear:

  1. Scale the cube along ONE of the axis (at this moment the texture should be stretched)
  2. Apply cube's scale (after this the texture should look as expected)

Two last steps recorded on Intel iGPU:

Here's blend file I used for the previews above:

This problem appears in the following versions: 2.83lts, 2.90, 2.91.0 alpha 66078594d130

It happened on NVidia 630M (Ubuntu 20.04), NVidia 1080 (Windows 10), AMD Radeon RX570 (Windows 10).

It looks like that the mapping issue was fixed for Intel in 2.83.6 8610c697773e since in 2.82 375c7dc4caf4 it looks stretched (as for NVidia/AMD in the images above).

Here are system-info files with corresponding GPUs on my laptop (Intel and NVidia 630M):


Event Timeline

After more investigation I found out that the node I should have been used to achieve the needed effect as shows on Intel's render is the Object output from the Texture Coordinate which properly behaves on both Intel and NVidia.

It looks like that there's something wrong with the Generated output when using Intel iGPU. I've included the commit hash of the versions where the problem started to appear.

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.Wed, Sep 16, 1:30 PM

Unfortunately I don't have intel GPU to confirm. Can you add intel GPU model and driver version to the report? You can use Help > Report a Bug to generate this information.

There are number of reports for intel GPU's so I suspect this is bug in their driver, and there's nothing we can do about it.

renderer: 'Mesa DRI Intel(R) HD Graphics 2000 (SNB GT1)'
vendor: 'Intel Open Source Technology Center'
version: '3.3 (Core Profile) Mesa 20.0.8'

Richard Antalik (ISS) closed this task as Invalid.Thu, Sep 17, 1:39 PM
Richard Antalik (ISS) claimed this task.

Thanks for the report. This GPU is below the minimum requirements for Blender, so there is no longer support for it. https://www.blender.org/download/requirements/

Installing the latest graphics driver sometimes helps to make such GPUs work, see here for more information. https://docs.blender.org/manual/en/dev/troubleshooting/gpu/index.html

If that doesn't help, you can use Blender 2.79: https://www.blender.org/download/previous-versions/