Page MenuHome

Unable to pose using the outliner
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1070 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.12

Blender Version
Broken: version: 2.91.0 Alpha, branch: master, commit date: 2020-09-11 09:14, hash: rB1b6dd42803df

Worked: (newest version of Blender that worked as expected)

Short description of error
Not able to select bones for posing. Normally a "bone" icon will appear after selecting "pose" in the outliner to allow posing.

Exact steps for others to reproduce the error
Open file.
Go to outliner.
Try to select "pose" to pose armature.

Screencap:

However when I select pose in the dropdown it will allow posing, it will also reflect on the outliner (but we still can't use outliner to turn it off or on, like before).

Screencap after the dropdown select:

Attached file:

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Developer to Reproduce.Mon, Sep 14, 9:56 AM

Behavior changed in rB2110af20f5e6: Outliner: Move mode toggling to left column, and as far as I can tell, this was a conscious decision.

See T68498: Outliner: Mode Toggling and D8641: Outliner: Add mode toggling column

@Nathan Craddock (Zachman) , @Campbell Barton (campbellbarton): I would assume this is can be closed, but a bit hesitant since I am not totally sure if I read those tasks correctly. This means there is not possibility to change mode from object-mode, right?

This was a conscious decision. The outliner only allowed entering edit and pose mode. The new mode column does not allow entering modes, but allows switching the active within all modes. Additionally, T63991: Outliner/Properties syncing will eventually be committed which will change the properties editor tab when clicking on mesh/pose data.

Entering the mode must be done from the viewport. It's possible to add a context menu operator in the outliner to enter other modes if needed though.

Richard Antalik (ISS) closed this task as Invalid.Thu, Sep 17, 4:05 PM
Richard Antalik (ISS) claimed this task.

Thanks for info, will close this then.